
  






<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://baytownsun.com/content/tncms/live/" />
<meta name="tncms-access-version" content="" />
<meta name="keywords" content="baytown, ernestine hunter, frazier, christianity, funeral service, funeral home, texas, viewing" />
<meta name="news_keywords" content="baytown, ernestine hunter, frazier, christianity, funeral service, funeral home, texas, viewing" />
<meta name="description" content="Ernestine Hunter (Ms. Chat) passed away on February 18, 2022. A funeral service will be at Unity Missionary Baptist Church, 2625 Broad St., Baytown, Texas 77521. Viewing will be at" />
<meta name="author" content="" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="googlebot" content="noarchive" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://baytownsun.com/obituaries/article_f08040d8-94cf-11ec-84d0-8b847333e4b3.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/05bdbe5a-c633-11e7-833d-a71de5d136a4.jpg?resize=600%2C315" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="315" />
<meta property="og:title" content="Ernestine Hunter (Ms. Chat)" />
<meta property="og:description" content="Ernestine Hunter (Ms. Chat) passed away on February 18, 2022. A funeral service will be at Unity Missionary Baptist Church, 2625 Broad St., Baytown, Texas 77521. Viewing will be at" />
<meta property="og:site_name" content="BaytownSun.com" />
<meta property="og:section" content="Obituaries" />
<meta property="fb:app_id" content="154556984575732" />
<meta property="article:publisher" content="https://www.facebook.com/BaytownSun" />
<meta name="twitter:image" content="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/6/e6/6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb/6216731025bf5.image.jpg?crop=188%2C188%2C4%2C0&amp;resize=144%2C144&amp;order=crop%2Cresize" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@TheBaytownSun" />
<meta name="twitter:image:alt" content="Ernestine Hunter (Ms. Chat)" />
<meta property="tncms:subs" content="2.0" />
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.c58a1beaa3640fa94c3db09673c4d95c.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.e3f8c8eeaa897ac944c740cf9d63deb5.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.feb84265ed22ec1b578ffb91ddb31be4.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-text-promo.945a2efac4892ce469180c513f411107.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-classifieds-bulletins.a78f8be1f6e0dabcb5acb9a8939501f8.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"product":{"software":"BLOX","version":"1.61.3"},"crm":{"group_id":"237"}},"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"simple","style":"default","path":"\/obituaries","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"true"},"asset":{"type":"article","start_hour":"11","id":"f08040d8-94cf-11ec-84d0-8b847333e4b3","app":"editorial","ga_page":"\/obituaries\/article_f08040d8-94cf-11ec-84d0-8b847333e4b3.html"},"vendor":{"outbrain":"disabled","taboola":""},"ad":{"vendor":"blox"},"system":{"render_time":315},"client":{"is_bot":"no","is_gdpr":"no"},"google":{"ua":"UA-1733861-4"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="https://tags.crwdcntrl.net/c/14694/cc.js?ns=_cc14694" id="LOTCC_14694"></script>
<script>
	if(document.cookie.indexOf('tncms-dmp-id') != -1) {
		_cc14694.add('tp', 'TNNW');
		_cc14694.add('act', ' User Login');
		_cc14694.add('tpid', document.cookie.split( ';' ).map( function( x ) { return x.trim().split( '=' ); } ).reduce(function( a, b ) { a[ b[ 0 ] ] = b[ 1 ]; return a; }, {} )[ "tncms-dmp-id"]);
		document.cookie = 'tncms-dmp-id=;expires=Thu, 01 Jan 1970 00:00:01 GMT';
		sessionStorage.removeItem('tncms.behaviors');
		sessionStorage.removeItem('tncms.dmp.audiences');
	}
	_cc14694.bcp();
</script>

<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="/shared-content/art/tncms/subscription.js"></script>
<script>/*<![CDATA[*/ TNCMS.Subscription.initialize({"service_id": "92,93,5151,5686,7941", "prefix": ""}); /*]]>*/</script>
<script type="module" async="async" src="/shared-content/art/tncms/api/access.js"></script>
<script src="/shared-content/art/tncms/api/access-legacy.js" defer="defer" nomodule="nomodule"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.d6d18fcf88750a16d256e72626e676a6.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.08a61544f369cc43bf02e71b2d10d49f.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.394adeeb6831ca20cb80bc3489a2f345.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.cb897187c4718280fd69d2e6d6c3909d.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.init.c2b9574823d0d16ffc6f20eef83f4232.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.load.6a3c47703ee96f20ef132e36033ca1bc.js"></script>
<script src="/shared-content/art/tncms-ad-manager/admanager.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/ads/impressions.js?_dc=1645677303"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/ads/traffic.js?_dc=1645598102"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/ads/settings.js?_dc=1624900419"></script>
<script src="/shared-content/art/tncms/user-manage/resources/scripts/decrypt.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.status.828de94349981272665c0fb0107f3e49.js"></script>
<script>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</script>
<script src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.7a9170240d21440159b9bd59db72933b.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};
    __tnt.ads.dfp.dmp = __tnt.ads.dfp.dmp || {};
    __tnt.ads.dfp.dmp.audienceCheck = function(settings) {
        if (!__tnt.client.capabilities.supportsLocalStorage() || localStorage.getItem('tncms.dmp.audiences') == null) return false;
        if (settings.block && typeof settings.audience != 'undefined' && settings.audience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), settings.audience.split(','))) return true;
        } else if (typeof __tnt.ads.dfp.dmp.hideAudience != 'undefined' && __tnt.ads.dfp.dmp.hideAudience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), __tnt.ads.dfp.dmp.hideAudience)) return true;
        }
        return false;
    };

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};
    __tnt.ads.dfp.targeting.k = ["baytown","ernestine hunter","frazier","christianity","funeral service","funeral home","texas","viewing"];

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        cube:"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/cube.d862aac30e9cb24516c7474509403c47.js",
        interstitial:"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/interstitial.7047e23fde50ef7dc7625903de95abec.js",
        nativeArticle:"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/native-article.9b3cd3bb8591bed71346f4fe429b96dc.js",
        pageCurl:"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/parallax.0ce32932f3b4125f930bea8d431f8f03.js",
        paw:"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/paw.3dd6ca40ac90c6df07356392c8489f72.js",
        pencil:"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/pencil.8cf6eeafd9d2d9371b611e86c7c099c1.js",
        reveal:"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/reveal.e5d561a6b71aa2730a07fa90f5f4f6d6.js",
        roller:"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/roller.c699c542afb9f08b38613e8473ddf14f.js",
        slider:"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/slider.015001bff591d1665c6d0ec2a888b1ca.js",
        stickyAnchor:"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/sticky-anchor.6dc181cbc3d60e2a1892d05998349ef6.js",
        video:"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/video-inline.9b0997ab77d1d69707d283848faeacdd.js",
        wallpaper:"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/wallpaper.dc1c1bace62343a130be3589fe0846f9.js"
    }; /*]]>*/</script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.283bfb49ef55c073fceda15ffbf58de8.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/ads/fixed-big-ad-top-asset/1.js?_dc=1644408063"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/ads/fixed-big-ad-bottom-asset/1.js?_dc=1644408063"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/ads/fixed-big-ad-top/1.js?_dc=1644408063"></script>
<script>/*<![CDATA[*/ window.poll_config || (window.poll_config = []); window.poll_config.push({"id":"9b9e9a48-9104-11ec-abf7-e7fa4d6542ec-1505068","asset_id":"9b9e9a48-9104-11ec-abf7-e7fa4d6542ec","title":"For the March 1 Primary Election, Texans vote via mail, during early voting or on Election Day. How did you vote or plan to vote in the primary?","url":"\/local\/poll_9b9e9a48-9104-11ec-abf7-e7fa4d6542ec.html","results":"https:\/\/baytownsun.com\/local\/poll_9b9e9a48-9104-11ec-abf7-e7fa4d6542ec.html?action=poll:results&format=json","chart":"bar"}); /*]]>*/</script>
<script>/*<![CDATA[*/ window.maillist_signup_config || (window.maillist_signup_config = []); window.maillist_signup_config.push({"heading_tag":"h4","list_ids":"","require_user_account":"1","signup_lists_only":"","heading_bg_color":"","heading_text_color":"inherit","note":"","links_position":"top","bg_color":"","text_color":"inherit","sign_up_text":"Sign up","manage_button_text":"Manage your lists","show_select_all":"","show_audience":"","hide_audience":"","block_id":"1505149"}); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/ads/fixed-big-ad-middle/1.js?_dc=1644148861"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/ie.grid.placement.8d31e32afeebe4520bfab9638ef91435.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/ads/fixed-big-ad-bottom/1.js?_dc=1644148861"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.pop();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>Ernestine Hunter (Ms. Chat) | Obituaries | baytownsun.com</title>
            
    <style>body { background-color: #ffffff; color: #333333; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #4175aa; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #ffffff; } .tnt-content-width-container > * { max-width: 1140px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #304977; } .fixed-nav #main-navigation { background-color: #304977 !important; } #site-top-nav-container, #site-top-nav { background-color: #ffffff; } #site-footer-container, #site-footer { background-color: #f7f9ff; color: #000000; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus, .navbar-default .navbar-nav>li>button.nav-link, .navbar-default .navbar-nav>li>button.nav-link:hover, .navbar-default .navbar-nav>li>button.nav-link:focus, .navbar-default .navbar-nav>.open>button.nav-link, .navbar-default .navbar-nav>.open>button.nav-link:hover, .navbar-default .navbar-nav>.open>button.nav-link:focus{ color: #000000; } .navbar-toggle .icon-bar { background-color: #000000 !important; } .navbar-toggle .sr-only-show { color: #000000 !important; } #site-top-nav .list-inline>li>a { color: #000000; } .asset .asset-body p, .asset #asset-content p { color: #000; } #site-header-container { background-color: #ffffff; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }/* full span block region */ #main-bottom-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #000000; } }#site-top-nav .list-inline>li>a.btn:not(.btn-link) { color: #fff; }#site-copyright a, #site-footer a { color: #000000; }.search-redesign .top-breakout > .row { max-width: 1200px; }.nav-tabs>li.active>a, .nav-tabs>li.active>a:hover, .nav-tabs>li.active>a:focus { border-top-color: #2f3887; }#site-header-container{ border-bottom: 3px solid #2f3887; }#site-footer-container{ border-top: 3px solid #2f3887; } .tnt-bg-accent { background-color: #2f3887; } a .tnt-caret-down { color: #2f3887; } .block-title .block-title-inner { border-color: #2f3887; } a.thumbnail:hover, a.thumbnail:focus, a.thumbnail.active { border-color: #2f3887; } .form-control:focus { border-bottom-color: #2f3887; } /* CSS has moved to Site templates/Global skins/flexsystem/resources/site.css.inc.utl */ </style> <!-- site.css.inc.utl has been included. --> <!-- NOTE: anything in an include file, outside of UTL tags , will be output on the page --> <style>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</style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://baytownsun.com/content/tncms/site/icon.ico" />
    
        <link rel="apple-touch-icon" href="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/a743b2cc-72fd-11ec-9ec7-f3a4cdc1576b.png" />
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    
        <link rel="preconnect" href="//bcp.crwdcntrl.net">
    
        <link rel="preconnect" href="//tags.crwdcntrl.net">
    <link rel="alternate" type="application/rss+xml" title="Ernestine Hunter (Ms. Chat) | Obituaries | baytownsun.com" href="http://baytownsun.com/search/?f=rss&amp;t=article&amp;c=obituaries&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://baytownsun.com/obituaries/article_f08040d8-94cf-11ec-84d0-8b847333e4b3.html" />
            <script defer src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.3aa64d478db9cdd63e9d4b159e0c9334.js"></script>
            <script type="text/javascript">

$(document).ready(function(){




var sInjectNavIcon = "<svg class=\"tnt-svg tnt-star tnt-w-18\" aria-hidden=\"true\" data-prefix=\"fas\" data-icon=\"star\" role=\"img\" xmlns=\"http://www.w3.org/2000/svg\" viewBox=\"0 0 576 512\" data-fa-i2svg=\"\"><path fill=\"currentColor\" d=\"M259.3 17.8L194 150.2 47.9 171.5c-26.2 3.8-36.7 36.1-17.7 54.6l105.7 103-25 145.5c-4.5 26.3 23.2 46 46.4 33.7L288 439.6l130.7 68.7c23.2 12.2 50.9-7.4 46.4-33.7l-25-145.5 105.7-103c19-18.5 8.5-50.8-17.7-54.6L382 150.2 316.7 17.8c-11.7-23.6-45.6-23.9-57.4 0z\"></path></svg>";


    $(sInjectNavIcon).insertBefore('.nav-link.nav-home .nav-label');
    $('.tnt-svg.tnt-home.tnt-w-18.nav-icon.tnt-fw').css('display','none');



});






</script>
        </head>
        <body class="app-editorial grid-simple blox-asset uuid-f08040d8-94cf-11ec-84d0-8b847333e4b3  section-obituaries type-article infinity-disabled" data-path="/obituaries">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('baytownsun.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;townnews.product.software=BLOX&amp;townnews.product.version=1.61.3&amp;townnews.crm.group_id=237&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=simple&amp;tncms.page.style=default&amp;tncms.page.path=%2Fobituaries&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=true&amp;tncms.asset.type=article&amp;tncms.asset.start_hour=11&amp;tncms.asset.id=f08040d8-94cf-11ec-84d0-8b847333e4b3&amp;tncms.asset.app=editorial&amp;tncms.asset.ga_page=%2Fobituaries%2Farticle_f08040d8-94cf-11ec-84d0-8b847333e4b3.html&amp;tncms.vendor.outbrain=disabled&amp;tncms.vendor.taboola=&amp;tncms.ad.vendor=blox&amp;tncms.system.render_time=315&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.google.ua=UA-1733861-4&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <a href="#main-page-container" class="sr-only" onclick="document.getElementById('main-page-container').scrollIntoView(); return false">Skip to main content</a><div id="fb-root"></div>
        
        <script type="text/javascript">
TNCMS.AdManager.init
({
  domain: "baytownsun.com",
  secureDomain: "baytownsun.com",
  virtualregion: {
            popup: __tnt.ads.popup
        },
  callback: {
            expandable: __tnt.ads.expandable,
            html: __tnt.ads.html,
            image: __tnt.ads.image,
            pagecurl: __tnt.ads.curl,
            text: __tnt.ads.text,
            video: __tnt.ads.video
        }
});
</script>

        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"page-curl","id":"page-curl","pos":"page-curl, atf","fold":"above","size":"[[75,75]]","height":"75","width":"75","not_mobile":true,"refresh":false}' style="display:none;"></div>
        
        

    <div id="template-metering" data-message-mode="login">
    <template class="template meter subscription">
        <div class="meter message" data-message="blox subscription wall">
        <div class="wall panel panel-default">
            <div class="panel-body">
                <h4 class="meter-heading media-heading">
                    Thank you for reading!

                </h4>
                <p>Please <span class="not-logged-in">log in, or sign up for a new account and</span> purchase a subscription to continue reading.</p>

                <div class="col-xs-12">
                    <div class="row not-logged-in">

                        <div class="col-xs-6">
                            
    <a  class="btn btn-default btn-block" href="https://baytownsun.com/users/signup/?referer_url=https%3A%2F%2Fbaytownsun.com%2Fobituaries%2Farticle_f08040d8-94cf-11ec-84d0-8b847333e4b3.html">Sign Up</a>
                        </div>
                        <div class="col-xs-6">
                            
    <a class="btn btn-primary btn-block" href="https://baytownsun.com/users/login/?referer_url=https%3A%2F%2Fbaytownsun.com%2Fobituaries%2Farticle_f08040d8-94cf-11ec-84d0-8b847333e4b3.html">Log In</a>
                        </div>
                    </div>
                    <div class="row logged-in">
                        <div class="pull-right">
                            
    <a class="btn btn-default not-logged-in" href="https://baytownsun.com/users/login/?referer_url=https%3A%2F%2Fbaytownsun.com%2Fobituaries%2Farticle_f08040d8-94cf-11ec-84d0-8b847333e4b3.html">Log In</a>
                            <a class="btn btn-default logged-in" href="https://baytownsun.com/users/admin/service/purchase/?referer_url=https%253A%252F%252Fbaytownsun.com%252Fobituaries%252Farticle_f08040d8-94cf-11ec-84d0-8b847333e4b3.html">Purchase a Subscription
</a>
                        </div>
                    </div>
                    </div>
            </div>
        </div>
        </div>
    
    
</template>
    
    <template class="template meter registration">
        
    <div class="meter message wall panel panel-default" data-message="blox registration wall">
        <div class="panel-body">
            <h4 class="meter-heading media-heading">
                Thank you for reading!

            </h4>
            <p>Please <span class="not-logged-in">log in, or sign up for a new account</span> to continue reading.</p>

            <div class="col-xs-12">
                <div class="row not-logged-in">
                
                    <div class="col-xs-6">
                        
    <a  class="btn btn-default btn-block" href="https://baytownsun.com/users/signup/?referer_url=https%3A%2F%2Fbaytownsun.com%2Fobituaries%2Farticle_f08040d8-94cf-11ec-84d0-8b847333e4b3.html">Sign Up</a>
                    </div>
                    <div class="col-xs-6">
                        
    <a class="btn btn-primary btn-block" href="https://baytownsun.com/users/login/?referer_url=https%3A%2F%2Fbaytownsun.com%2Fobituaries%2Farticle_f08040d8-94cf-11ec-84d0-8b847333e4b3.html">Log In</a>
                    </div>
                </div>
                
                <div class="row logged-in">
                    <a class="btn btn-default" href="https://baytownsun.com/users/admin/service/purchase/?referer_url=https%253A%252F%252Fbaytownsun.com%252Fobituaries%252Farticle_f08040d8-94cf-11ec-84d0-8b847333e4b3.html">Purchase a Subscription
</a>
                </div>
            </div>
        </div>
    </div>
</template>
    
    <template class="template meter referred">
        <div class="meter notification referred alert alert-dismissable alert-info" data-message="blox user referred">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
         
        <p><strong>Thank you for reading!
</strong> We hope that you continue to enjoy our free content.</p>
    </div>
</template>
    
    
    
</div>
<script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                
                bloxServiceIDs.push(92);
                
                bloxServiceIDs.push(93);
                
                bloxServiceIDs.push(5151);
                
                bloxServiceIDs.push(5686);
                
                bloxServiceIDs.push(7941);
                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-top","id":"fixed-impact-top","pos":"fixed-impact-top, atf","fold":"above","include_domain":null,"size":"[2,1]","height":"1","width":"2","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/obituaries","refresh":false}' style="display:none;"></div>
        <div id="blox-ad-position-_popup1" data-tnt-ads='{"vendor":"blox","type":"position","region":"_popup","id":"_popup","slot":1,"pos":"_popup, atf","size":"[[900,900]]","height":"900","width":"900","display":"popup","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div>
        <div id="site-container"><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://baytownsun.com/tncms/admin/editorial-asset/?edit=f08040d8-94cf-11ec-84d0-8b847333e4b3"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        
    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left visible-sm visible-xs" aria-label="Left Main Menu" aria-expanded="false" tabindex="-1" >
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist" aria-hidden="true"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-1" data-target="#mobile-nav-left_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/"  class="nav-link tnt-section-home ">Home</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/about.html"  class="nav-link tnt-section-about-us">About Us</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/personnel.html"  class="nav-link tnt-section-staff">Staff</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://baytownsun.com/article_5d70043e-3676-11ec-b36b-a78424639d64.html"  target="_blank" rel="noopener" class="nav-link tnt-section-citizen-of-the-year-winners">Citizen of the Year Winners</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/history.html"  class="nav-link tnt-section-history">History</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/obituaries"  class="nav-link tnt-section-obits ">Obits</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-3" data-target="#mobile-nav-left_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/news"  class="nav-link tnt-section-news ">News</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/local/"  class="nav-link tnt-section-local">Local</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/weather"  class="nav-link tnt-section-weather">Weather</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/police/"  class="nav-link tnt-section-police">Police</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/lifestyle/"  class="nav-link tnt-section-lifestyle">Lifestyle</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/medical_news/"  class="nav-link tnt-section-medical-news">Medical News</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/communities"  class="nav-link tnt-section-communities ">Communities</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/sports"  class="nav-link tnt-section-sports ">Sports</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-6" data-target="#mobile-nav-left_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/opinion"  class="nav-link tnt-section-opinion ">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/editorials"  class="nav-link tnt-section-editorials">Editorials</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/columns/"  class="nav-link tnt-section-columns">Columns</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/guest_columns/"  class="nav-link tnt-section-guest-columns">Guest Columns</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/letters"  class="nav-link tnt-section-letters">Letters</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/online_services/letter"  class="nav-link tnt-section-write-a-letter">Write a Letter</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-7" data-target="#mobile-nav-left_menu-child-7">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true"   class="nav-link tnt-section-entertainment expand-label">Entertainment</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-7" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://baytownsun.com/app/TV.pdf"  target="_blank" rel="noopener" class="nav-link tnt-section-tv-listings">TV Listings</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://baytownsun.com/app/horoscopes.pdf"  target="_blank" rel="noopener" class="nav-link tnt-section-horoscopes">Horoscopes</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://baytownsun.com/app/Cipher.pdf"  target="_blank" rel="noopener" class="nav-link tnt-section-celebrity-cipher">Celebrity Cipher</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://baytownsun.com/app/Crossword.pdf"  target="_blank" rel="noopener" class="nav-link tnt-section-crossword-puzzle">Crossword Puzzle</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="http://baytownsun.com/app/Sudoku.pdf"  target="_blank" rel="noopener" class="nav-link tnt-section-sudoku">Sudoku</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/eedition"  class="nav-link tnt-section-sunspan-class-nav-icon-fas-fas-tnt-certificate-spane-editions ">Sun<span class="nav-icon fas fas tnt-certificate"></span>e-Editions</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-9" data-target="#mobile-nav-left_menu-child-9">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/site/advertise.html"  class="nav-link tnt-section-advertising ">Advertising</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-9" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/online_services/classified"  class="nav-link tnt-section-place-a-classified-ad">Place a Classified Ad</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/sales_team.html"  class="nav-link tnt-section-outside-sales-team">Outside Sales Team</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://baytownsun.snibilling.com"  target="_blank" rel="noopener" class="nav-link tnt-section-pay-an-advertising-invoice">Pay an Advertising Invoice</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds"  class="nav-link tnt-section-classifieds">Classifieds</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-10" data-target="#mobile-nav-left_menu-child-10">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/special_sections/"  class="nav-link tnt-section-special-sections ">Special Sections</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-10" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/multimedia/"  class="nav-link tnt-section-multimedia">Multimedia</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/magazines/"  class="nav-link tnt-section-magazines">Magazines</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-11" data-target="#mobile-nav-left_menu-child-11">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/site/forms/subscription_services/"  class="nav-link tnt-section-subscribe ">Subscribe</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-11" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/subscription_services/changeaddress/"  class="nav-link tnt-section-change-address">Change Address</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/subscription_services/vacation/"  class="nav-link tnt-section-vacation">Vacation</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/subscription_services/deliveryissue/"  class="nav-link tnt-section-delivery-issues">Delivery Issues</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/subscription_services/giftsubscribe/"  class="nav-link tnt-section-gift-subscription">Gift Subscription</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/subscription_services/greater_baytown_subscribe/"  class="nav-link tnt-section-greater-baytown">Greater Baytown</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/subscription_services/pay_subscription_online/"  class="nav-link tnt-section-pay-subscription-online">Pay Subscription Online</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/subscription_services/subscribe/"  class="nav-link tnt-section-subscribe">Subscribe</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://baytownsun.com/users/admin/service/purchase/?serviceid=7941"  target="_blank" rel="noopener" class="nav-link tnt-section-online-only-subscription">Online-Only Subscription</a>
                                </li></ul></div></div></div>
                
                
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "></div>
            </aside>
        
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    
    
    
    
    <div id="tncms-region-asset_skyline" class="tncms-region hidden-print"></div><div id="tncms-region-global-skyline" class="tncms-region "><div id="tncms-block-1825228" class="tncms-block hidden-xs hidden-sm"></div></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list" ><li class="dropdown" aria-expanded="false">
                <a class="nav-link   dropdown-toggle  tnt-section-subscribe"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"    tabindex="0" >
                    
                        <span class="fas tnt-caret-1"></span>
                    <span class="nav-label">Subscribe</span>
                </a><ul id="topbar-col-one-nav_menu-child-1" class="dropdown-menu" ><li>
                <a class="nav-link    tnt-section-the-baytown-sun"  href="/site/forms/subscription_services/subscribe"  tabindex="0" >
                    <span class="nav-label">The Baytown Sun</span>
                </a></li><li>
                <a class="nav-link    tnt-section-greater-baytown"  href="/site/forms/subscription_services/greater_baytown_subscribe/"  tabindex="0" >
                    <span class="nav-label">Greater Baytown</span>
                </a></li><li>
                <a class="nav-link    tnt-section-online-edition"  href="https://baytownsun.com/users/admin/service/purchase/?service_id=7941"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label">Online Edition</span>
                </a></li></ul></li><li>
                <a class="nav-link    tnt-section-renew"  href="/site/forms/subscription_services/paybill"  tabindex="0" >
                    <span class="nav-label">Renew</span>
                </a></li><li>
                <a class="nav-link    tnt-section-service"  href="/site/services"  tabindex="0" >
                    <span class="nav-label">Service</span>
                </a></li><li>
                <a class="nav-link    tnt-section-contact"  href="/site/personnel.html"  tabindex="0" >
                    <span class="nav-label">Contact</span>
                </a></li></ul></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-1505136" class="tncms-block"><div id="user-controls-1505136" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://baytownsun.com/users/signup/?referer_url=https%3A%2F%2Fbaytownsun.com%2Fobituaries%2Farticle_f08040d8-94cf-11ec-84d0-8b847333e4b3.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://baytownsun.com/users/login/?referer_url=https%3A%2F%2Fbaytownsun.com%2Fobituaries%2Farticle_f08040d8-94cf-11ec-84d0-8b847333e4b3.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://baytownsun.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-1505136').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://baytownsun.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://baytownsun.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://baytownsun.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-1505136').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://baytownsun.com/users/logout/" id="user-logout-form-1505136"><input type="hidden" name="referer_url" value="https://baytownsun.com/obituaries/article_f08040d8-94cf-11ec-84d0-8b847333e4b3.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-1505134" class="tncms-block margin-right"><div class="follow-links-1505134 pull-right">
    
    <section id="block-1505134" class="block emphasis-h4   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/BaytownSun" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/thebaytownsun" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
            <li>
                <a href="https://www.instagram.com/thebaytownsun/" title="Instagram" target="_blank" rel="noopener" class="btn btn-md btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://baytownsun.com",
  "sameAs" : ["https://www.facebook.com/BaytownSun","https://twitter.com/thebaytownsun","https://www.instagram.com/thebaytownsun/"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "><div id="tncms-block-2337847" class="tncms-block"><hr></div></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-3 col-sm-3"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-1505084" class="tncms-block logo-block"><section id="block-1505084" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow"  >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/b0650c8e-e755-11e8-a387-835f06914f5b.png?resize=150%2C18 150w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/b0650c8e-e755-11e8-a387-835f06914f5b.png?resize=200%2C24 200w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/b0650c8e-e755-11e8-a387-835f06914f5b.png?resize=225%2C27 225w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/b0650c8e-e755-11e8-a387-835f06914f5b.png?resize=300%2C36 300w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/b0650c8e-e755-11e8-a387-835f06914f5b.png?resize=400%2C47 400w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/b0650c8e-e755-11e8-a387-835f06914f5b.png?resize=540%2C64 540w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/b0650c8e-e755-11e8-a387-835f06914f5b.png?resize=640%2C76 640w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/b0650c8e-e755-11e8-a387-835f06914f5b.png 750w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="750"
                height="89"
                alt=""
                aria-hidden="true"></a></div></section></div></div></div>
    <div id="masthead-col-two" class="col-md-9 col-sm-9"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-1505138" class="tncms-block padding-top"><div id="weather-1505138" class="weather-current size-nav pull-right">
    <ul class="nav navbar-nav navbar-right">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=77520" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250" aria-label="Weather">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-night-cloudy"></span>
                </span>
                <span class="pull-left temp-desc nav">
                    <span class="temp">43&deg;</span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather Zip Code" value="77520">
                                <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a id="weather_zip_toggle_1505138" class="pull-right zip-update-link" aria-label="weather_zip_toggle"><span class="fas tnt-cog"></span></a><h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Baytown, TX
                                
                                <small>(77520)</small>
                            </h4><h5>Today</h5>
                                <p>Overcast. Slight chance of a rain shower. Low 42F. Winds N at 5 to 10 mph..
                                </p>
                                <h5>Tonight</h5>
                                <p>Overcast. Slight chance of a rain shower. Low 42F. Winds N at 5 to 10 mph.</p>
                                <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: February 23, 2022 @ 10:50 pm</small></p></div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center">
                        <a href="/weather/?weather_zip=77520"><i class="fas tnt-caret-right"></i> Full Forecast</a>
                    </li>
                </ul>
            
        </li>
    </ul>
</div>
</div><div id="tncms-block-1548613" class="tncms-block">
        <div id="blox-ad-position-Microbar1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"Microbar","slot":"1","fold":"","width":"88","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                    
                        <button type="button" class=" visible-sm visible-xs navbar-toggle pull-left" data-toggle="offcanvas" data-target="left" aria-label="Left Main Menu" aria-expanded="false">
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            
                        </button>
                         
                    
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_left">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1505129" class="tncms-block m"><section id="block-1505129" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow"  >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/b6e5c36e-e030-11e7-818c-5fcc65b5dc52.jpg?resize=150%2C21 150w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/b6e5c36e-e030-11e7-818c-5fcc65b5dc52.jpg?resize=200%2C28 200w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/b6e5c36e-e030-11e7-818c-5fcc65b5dc52.jpg?resize=225%2C31 225w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/b6e5c36e-e030-11e7-818c-5fcc65b5dc52.jpg?resize=300%2C41 300w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/b6e5c36e-e030-11e7-818c-5fcc65b5dc52.jpg?resize=400%2C55 400w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/b6e5c36e-e030-11e7-818c-5fcc65b5dc52.jpg?resize=540%2C74 540w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/b6e5c36e-e030-11e7-818c-5fcc65b5dc52.jpg?resize=640%2C88 640w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/b6e5c36e-e030-11e7-818c-5fcc65b5dc52.jpg 750w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="660"
                height="91"
                alt=""
                aria-hidden="true"></a></div></section></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-1505132" class="tncms-block"><ul id="site-search-1505132-dropdown" class="hidden-print nav navbar-nav navbar-right ">
        <li class="search-form-dropdown dropdown">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle" data-hover="dropdown" data-hover-delay="250" data-toggle="dropdown" aria-label="Search">
                <span class="fas tnt-search"></span>
            </a>
            <ul class="dropdown-menu">
                <li><form id="site-search-1505132" aria-labelledby="site-search-button-1505132" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div id="site-search-form-1505132" class="site-search-form input-group pull-right normal ">
        <input id="site-search-1505132-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1505132-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span id="site-search-button-1505132" class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
</div></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav" role="navigation" aria-label="Main"><li class="dropdown" aria-expanded="false">
                <a class="nav-link   nav-home dropdown-toggle  tnt-section-home"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/"  tabindex="0" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a><ul id="main-nav_menu-child-1" class="dropdown-menu" ><li>
                <a class="nav-link    tnt-section-about-us"  href="/site/about.html"  tabindex="0" >
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link    tnt-section-staff"  href="/site/personnel.html"  tabindex="0" >
                    <span class="nav-label">Staff</span>
                </a></li><li>
                <a class="nav-link    tnt-section-citizen-of-the-year-winners"  href="https://baytownsun.com/article_5d70043e-3676-11ec-b36b-a78424639d64.html"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label">Citizen of the Year Winners</span>
                </a></li><li>
                <a class="nav-link    tnt-section-history"  href="/site/history.html"  tabindex="0" >
                    <span class="nav-label">History</span>
                </a></li></ul></li><li>
                <a class="nav-link    tnt-section-obits"  href="/obituaries"  tabindex="0" >
                    <span class="nav-label">Obits</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link   dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news"  tabindex="0" >
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-3" class="dropdown-menu" ><li>
                <a class="nav-link    tnt-section-local"  href="/local/"  tabindex="0" >
                    <span class="nav-label">Local</span>
                </a></li><li>
                <a class="nav-link    tnt-section-weather"  href="/weather"  tabindex="0" >
                    <span class="nav-label">Weather</span>
                </a></li><li>
                <a class="nav-link    tnt-section-police"  href="/news/police/"  tabindex="0" >
                    <span class="nav-label">Police</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link   dropdown-toggle  tnt-section-lifestyle"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="/lifestyle/"  tabindex="0" >
                    
                        <span class="fas tnt-caret-right"></span>
                    <span class="nav-label">Lifestyle</span>
                </a><ul id="main-nav_menu-child-3-child-4" class="dropdown-menu" ><li>
                <a class="nav-link    tnt-section-religion"  href="/lifestyle/religion/"  tabindex="0" >
                    <span class="nav-label">Religion</span>
                </a></li></ul></li><li>
                <a class="nav-link    tnt-section-medical-news"  href="/news/medical_news/"  tabindex="0" >
                    <span class="nav-label">Medical News</span>
                </a></li></ul></li><li>
                <a class="nav-link    tnt-section-communities"  href="/communities"  tabindex="0" >
                    <span class="nav-label">Communities</span>
                </a></li><li>
                <a class="nav-link    tnt-section-sports"  href="/sports"  tabindex="0" >
                    <span class="nav-label">Sports</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link   dropdown-toggle  tnt-section-opinion"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/opinion"  tabindex="0" >
                    <span class="nav-label">Opinion</span>
                </a><ul id="main-nav_menu-child-6" class="dropdown-menu" ><li>
                <a class="nav-link    tnt-section-editorials"  href="/opinion/editorials"  tabindex="0" >
                    <span class="nav-label">Editorials</span>
                </a></li><li>
                <a class="nav-link    tnt-section-columns"  href="/opinion/columns/"  tabindex="0" >
                    <span class="nav-label">Columns</span>
                </a></li><li>
                <a class="nav-link    tnt-section-guest-columns"  href="/opinion/guest_columns/"  tabindex="0" >
                    <span class="nav-label">Guest Columns</span>
                </a></li><li>
                <a class="nav-link    tnt-section-letters"  href="/opinion/letters"  tabindex="0" >
                    <span class="nav-label">Letters</span>
                </a></li><li>
                <a class="nav-link    tnt-section-write-a-letter"  href="/site/forms/online_services/letter"  tabindex="0" >
                    <span class="nav-label">Write a Letter</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link   dropdown-toggle  tnt-section-entertainment"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"    tabindex="0" >
                    <span class="nav-label">Entertainment</span>
                </a><ul id="main-nav_menu-child-7" class="dropdown-menu" ><li>
                <a class="nav-link    tnt-section-tv-listings"  href="http://baytownsun.com/app/TV.pdf"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label">TV Listings</span>
                </a></li><li>
                <a class="nav-link    tnt-section-horoscopes"  href="http://baytownsun.com/app/horoscopes.pdf"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label">Horoscopes</span>
                </a></li><li>
                <a class="nav-link    tnt-section-celebrity-cipher"  href="http://baytownsun.com/app/Cipher.pdf"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label">Celebrity Cipher</span>
                </a></li><li>
                <a class="nav-link    tnt-section-crossword-puzzle"  href="http://baytownsun.com/app/Crossword.pdf"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label">Crossword Puzzle</span>
                </a></li><li>
                <a class="nav-link    tnt-section-sudoku"  href="http://baytownsun.com/app/Sudoku.pdf"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label">Sudoku</span>
                </a></li></ul></li><li>
                <a class="nav-link    tnt-section-sunspan-class-nav-icon-fas-fas-tnt-certificate-spane-editions"  href="/eedition"  tabindex="0" >
                    <span class="nav-label">Sun<span class="nav-icon fas fas tnt-certificate"></span>e-Editions</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link   dropdown-toggle  tnt-section-advertising"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/site/advertise.html"  tabindex="0" >
                    <span class="nav-label">Advertising</span>
                </a><ul id="main-nav_menu-child-9" class="dropdown-menu" ><li>
                <a class="nav-link    tnt-section-place-a-classified-ad"  href="/site/forms/online_services/classified"  tabindex="0" >
                    <span class="nav-label">Place a Classified Ad</span>
                </a></li><li>
                <a class="nav-link    tnt-section-outside-sales-team"  href="/site/sales_team.html"  tabindex="0" >
                    <span class="nav-label">Outside Sales Team</span>
                </a></li><li>
                <a class="nav-link    tnt-section-pay-an-advertising-invoice"  href="https://baytownsun.snibilling.com"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label">Pay an Advertising Invoice</span>
                </a></li><li>
                <a class="nav-link    tnt-section-classifieds"  href="/classifieds"  tabindex="0" >
                    <span class="nav-label">Classifieds</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link   dropdown-toggle  tnt-section-special-sections"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/special_sections/"  tabindex="0" >
                    <span class="nav-label">Special Sections</span>
                </a><ul id="main-nav_menu-child-10" class="dropdown-menu" ><li>
                <a class="nav-link    tnt-section-multimedia"  href="/multimedia/"  tabindex="0" >
                    <span class="nav-label">Multimedia</span>
                </a></li><li>
                <a class="nav-link    tnt-section-magazines"  href="/magazines/"  tabindex="0" >
                    <span class="nav-label">Magazines</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link   dropdown-toggle  tnt-section-subscribe"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/site/forms/subscription_services/"  tabindex="0" >
                    <span class="nav-label">Subscribe</span>
                </a><ul id="main-nav_menu-child-11" class="dropdown-menu" ><li>
                <a class="nav-link    tnt-section-change-address"  href="/site/forms/subscription_services/changeaddress/"  tabindex="0" >
                    <span class="nav-label">Change Address</span>
                </a></li><li>
                <a class="nav-link    tnt-section-vacation"  href="/site/forms/subscription_services/vacation/"  tabindex="0" >
                    <span class="nav-label">Vacation</span>
                </a></li><li>
                <a class="nav-link    tnt-section-delivery-issues"  href="/site/forms/subscription_services/deliveryissue/"  tabindex="0" >
                    <span class="nav-label">Delivery Issues</span>
                </a></li><li>
                <a class="nav-link    tnt-section-gift-subscription"  href="/site/forms/subscription_services/giftsubscribe/"  tabindex="0" >
                    <span class="nav-label">Gift Subscription</span>
                </a></li><li>
                <a class="nav-link    tnt-section-greater-baytown"  href="/site/forms/subscription_services/greater_baytown_subscribe/"  tabindex="0" >
                    <span class="nav-label">Greater Baytown</span>
                </a></li><li>
                <a class="nav-link    tnt-section-pay-subscription-online"  href="/site/forms/subscription_services/pay_subscription_online/"  tabindex="0" >
                    <span class="nav-label">Pay Subscription Online</span>
                </a></li><li>
                <a class="nav-link    tnt-section-subscribe"  href="/site/forms/subscription_services/subscribe/"  tabindex="0" >
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link    tnt-section-online-only-subscription"  href="https://baytownsun.com/users/admin/service/purchase/?serviceid=7941"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label">Online-Only Subscription</span>
                </a></li></ul></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "><div id="tncms-block-1627784" class="tncms-block">
        <div id="blox-ad-position-block-pencil-top1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-pencil-top","slot":"1","fold":"span","width":"960","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-1505025" class="tncms-block hidden-xs">
        <div id="blox-ad-position-block-leaderboard-top1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top","slot":"1","fold":"above","width":"728","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1505026" class="tncms-block visible-xs visible-sm">
        <div id="blox-ad-position-block-leaderboard-top-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top-mobile","slot":"1","fold":"above","width":"320","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1871504" class="tncms-block">
</div></div></div>
        </div><div id="modal-image-6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb" class="modal fullscreen in modal-image image-default modal-6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                
                
                <img
                        src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/6/e6/6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb/6216731025bf5.image.jpg"
                        srcset="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/6/e6/6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb/6216731025bf5.image.jpg?resize=150%2C142 150w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/6/e6/6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb/6216731025bf5.image.jpg?resize=198%2C188 200w"
                        sizes="100vw"
                        
                        width="198"
                        height="188"
                        alt="Ernestine Hunter (Ms. Chat)"
                        class="img-responsive true-size default" />
                
                
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb" data-target=".caption-inner-modal-image-6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb collapse in"><div class="caption-text"></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fbaytownsun.com%2Fimage_6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/image_6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Ernestine%20Hunter%20%28Ms.%20Chat%29&via=TheBaytownSun&url=https%3A%2F%2Fbaytownsun.com%2Fimage_6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/image_6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://baytownsun.com/image_6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/image_6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20baytownsun.com/tncms/asset/editorial/6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BBaytown%20Sun%5D%20Ernestine%20Hunter%20%28Ms.%20Chat%29&body=https%3A%2F%2Fbaytownsun.com%2Fimage_6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/image_6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb" class="save-list-6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb img { max-height: 188px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-f08040d8-94cf-11ec-84d0-8b847333e4b3" class="asset article-default"  data-url="https://baytownsun.com/obituaries/article_f08040d8-94cf-11ec-84d0-8b847333e4b3.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span>
    <meta itemprop="description" content="Ernestine Hunter (Ms. Chat) passed away on February 18, 2022. A funeral service will be at Unity Missionary Baptist Church, 2625 Broad St., Baytown, Texas 77521. Viewing will be at 10 to 11 a.m., immediately followed by the funeral. Arrangements are under the direction of Frazier Funeral Home in Baytown, TX. "/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/05bdbe5a-c633-11e7-833d-a71de5d136a4.jpg?resize=600%2C315">
            <meta itemprop="width" content="600">
            <meta itemprop="height" content="315">
        </div>
        <meta itemprop="name" content="baytownsun.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://baytownsun.com/obituaries/article_f08040d8-94cf-11ec-84d0-8b847333e4b3.html" />
    <style>
                .asset-paging .direction {
                    color: #2f3887;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":true,"nextUrl":"https:\/\/baytownsun.com\/tncms\/search\/mlt\/?origin=f08040d8-94cf-11ec-84d0-8b847333e4b3&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"f08040d8-94cf-11ec-84d0-8b847333e4b3","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-f08040d8-94cf-11ec-84d0-8b847333e4b3" class="asset-paging">
                <div id="paging-prev-f08040d8-94cf-11ec-84d0-8b847333e4b3" class="paging-link prev offset"></div>
                <div id="paging-next-f08040d8-94cf-11ec-84d0-8b847333e4b3" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    <div class="tow-wrapper no-flags">
        
        
    </div>
    <h1 itemprop="headline" class="headline">
        <span>
            
            Ernestine Hunter (Ms. Chat)
        </span>
    </h1>
    <h2 itemprop="alternativeHeadline" class="subhead">
            <span>1928 - 2022</span>
        </h2><div class="meta">
        <span>
            <ul class="list-inline">
        
        
            <li class="visible-print">
        <time datetime="2022-02-23T11:42:00-06:00" class="tnt-date asset-date text-muted">
            Feb 23, 2022
        </time></li>
            <li class="hidden-print">
        <time datetime="2022-02-23T11:42:00-06:00" class="tnt-date asset-date text-muted">11 hrs ago</time></li>
        
        
            <li class="hidden-print"></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2022-02-23T11:42:00-06:00">
    <meta itemprop="datePublished" content="2022-02-23T11:42:00-06:00">
    <meta itemprop="dateModified" content="2022-02-23T11:42:00-06:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fbaytownsun.com%2Fobituaries%2Farticle_f08040d8-94cf-11ec-84d0-8b847333e4b3.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/article_f08040d8-94cf-11ec-84d0-8b847333e4b3.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f08040d8-94cf-11ec-84d0-8b847333e4b3"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Ernestine%20Hunter%20%28Ms.%20Chat%29&via=TheBaytownSun&url=https%3A%2F%2Fbaytownsun.com%2Fobituaries%2Farticle_f08040d8-94cf-11ec-84d0-8b847333e4b3.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/article_f08040d8-94cf-11ec-84d0-8b847333e4b3.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f08040d8-94cf-11ec-84d0-8b847333e4b3"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://baytownsun.com/obituaries/article_f08040d8-94cf-11ec-84d0-8b847333e4b3.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/obituaries/article_f08040d8-94cf-11ec-84d0-8b847333e4b3.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f08040d8-94cf-11ec-84d0-8b847333e4b3"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20baytownsun.com/tncms/asset/editorial/f08040d8-94cf-11ec-84d0-8b847333e4b3" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"f08040d8-94cf-11ec-84d0-8b847333e4b3"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BBaytown%20Sun%5D%20Ernestine%20Hunter%20%28Ms.%20Chat%29&body=https%3A%2F%2Fbaytownsun.com%2Fobituaries%2Farticle_f08040d8-94cf-11ec-84d0-8b847333e4b3.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"f08040d8-94cf-11ec-84d0-8b847333e4b3"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div class="asset-photo card"><figure class="photo layout-horizontal hover-expand letterbox-style-default"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-target=".modal-6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb" 
                    >
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-target=".modal-6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb" 
                    >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="198">
            <meta itemprop="height" content="188">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/6/e6/6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb/6216731025bf5.image.jpg">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/6/e6/6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb/6216731025bf5.image.jpg"><img
                        src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/6/e6/6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb/6216731025bf5.image.jpg"
                        srcset="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/6/e6/6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb/6216731025bf5.image.jpg?resize=150%2C142 150w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/6/e6/6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb/6216731025bf5.image.jpg?resize=198%2C188 200w"
                        sizes="(min-width: 1200px) 750px, (min-width: 992px) calc(66.70vw - 60px), calc(100vw - 30px)"
                        
                        width="198"
                        height="188"
                        alt="Ernestine Hunter (Ms. Chat)"
                        class="img-responsive full tnt-restrict-img-6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb default" />
            </div><style>
                .tnt-restrict-img-6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb {
                    max-width: 198px;
                }
            </style>
                
                
            </div>
            
                
                
            
        </figure></div>

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="f08040d8-94cf-11ec-84d0-8b847333e4b3">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fbaytownsun.com%2Fobituaries%2Farticle_f08040d8-94cf-11ec-84d0-8b847333e4b3.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/article_f08040d8-94cf-11ec-84d0-8b847333e4b3.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f08040d8-94cf-11ec-84d0-8b847333e4b3"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Ernestine%20Hunter%20%28Ms.%20Chat%29&via=TheBaytownSun&url=https%3A%2F%2Fbaytownsun.com%2Fobituaries%2Farticle_f08040d8-94cf-11ec-84d0-8b847333e4b3.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/article_f08040d8-94cf-11ec-84d0-8b847333e4b3.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f08040d8-94cf-11ec-84d0-8b847333e4b3"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://baytownsun.com/obituaries/article_f08040d8-94cf-11ec-84d0-8b847333e4b3.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/obituaries/article_f08040d8-94cf-11ec-84d0-8b847333e4b3.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f08040d8-94cf-11ec-84d0-8b847333e4b3"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20baytownsun.com/tncms/asset/editorial/f08040d8-94cf-11ec-84d0-8b847333e4b3" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"f08040d8-94cf-11ec-84d0-8b847333e4b3"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BBaytown%20Sun%5D%20Ernestine%20Hunter%20%28Ms.%20Chat%29&body=https%3A%2F%2Fbaytownsun.com%2Fobituaries%2Farticle_f08040d8-94cf-11ec-84d0-8b847333e4b3.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"f08040d8-94cf-11ec-84d0-8b847333e4b3"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/obituaries/article_f08040d8-94cf-11ec-84d0-8b847333e4b3.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f08040d8-94cf-11ec-84d0-8b847333e4b3"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-f08040d8-94cf-11ec-84d0-8b847333e4b3-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="f08040d8-94cf-11ec-84d0-8b847333e4b3" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="f08040d8-94cf-11ec-84d0-8b847333e4b3" class="save-list-f08040d8-94cf-11ec-84d0-8b847333e4b3-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="f08040d8-94cf-11ec-84d0-8b847333e4b3" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="false"/>
                                
                                
                                <div class="subscriber-preview"><p>Ernestine Hunter (Ms. Chat) passed away on February 18, 2022. A funeral service will be at Unity Missionary Baptist Church, 2625 Broad St., Baytown, Texas 77521. Viewing will be at 10 to 11 a.m., immediately followed by the funeral. Arrangements are under the direction of Frazier Funeral Home in Baytown, TX.</p></div><div class="subscriber-preview"><p>Ernestine Hunter (Ms. Chat) went to be with the Lord on February 18, 2022.</p></div><noscript><div class="meter notification wall alert alert-dismissable alert-warning hidden-print" data-message="blox noscript">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <h4 class="clearfix meter-heading  media-heading row">
            This page requires Javascript.
        </h4>
        <p>Javascript is required for you to be able to read premium content. <strong>Please enable it in your browser settings.</strong></p>
    </div></noscript><div class="subscriber-only encrypted-content" style="display:none">kAm$96 H2D 3@C? pAC:= `h[ `hag[ :? }6H (2G6C=6J[ %6I2D]k^Am</div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top-asset","id":"fixed-big-ad-top-asset","pos":"fixed-big-ad-top-asset, atf","fold":"above","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/obituaries","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-top-asset" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-top-asset1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-top-asset', slot: 1, fold: "above"});</script>

</div>
</div>
<div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><div class="subscriber-only encrypted-content" style="display:none">kAmp 7F?6C2= D6CG:46 H:== 36 2E &amp;?:EJ |:DD:@?2CJ q2AE:DE r9FC49[ aead qC@25 $E][ q2JE@H?[ %6I2D ffda`] ':6H:?8 H:== 36 2E `_ E@ `` 2]&gt;][ :&gt;&gt;65:2E6=J 7@==@H65 3J E96 7F?6C2=]k^Am</div><div class="subscriber-only encrypted-content" style="display:none">kAmpCC2?86&gt;6?ED 2C6 F?56C E96 5:C64E:@? @7 uC2K:6C uF?6C2= w@&gt;6 :? q2JE@H?[ %)]k^Am</div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom-asset","id":"fixed-big-ad-bottom-asset","pos":"fixed-big-ad-bottom-asset, btf","fold":"below","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/obituaries","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-bottom-asset" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-bottom-asset1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-bottom-asset', slot: 1, fold: "below"});</script>

</div>
</div>
<div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fbaytownsun.com%2Fobituaries%2Farticle_f08040d8-94cf-11ec-84d0-8b847333e4b3.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/article_f08040d8-94cf-11ec-84d0-8b847333e4b3.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f08040d8-94cf-11ec-84d0-8b847333e4b3"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Ernestine%20Hunter%20%28Ms.%20Chat%29&via=TheBaytownSun&url=https%3A%2F%2Fbaytownsun.com%2Fobituaries%2Farticle_f08040d8-94cf-11ec-84d0-8b847333e4b3.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/article_f08040d8-94cf-11ec-84d0-8b847333e4b3.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f08040d8-94cf-11ec-84d0-8b847333e4b3"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://baytownsun.com/obituaries/article_f08040d8-94cf-11ec-84d0-8b847333e4b3.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/obituaries/article_f08040d8-94cf-11ec-84d0-8b847333e4b3.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f08040d8-94cf-11ec-84d0-8b847333e4b3"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20baytownsun.com/tncms/asset/editorial/f08040d8-94cf-11ec-84d0-8b847333e4b3" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"f08040d8-94cf-11ec-84d0-8b847333e4b3"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BBaytown%20Sun%5D%20Ernestine%20Hunter%20%28Ms.%20Chat%29&body=https%3A%2F%2Fbaytownsun.com%2Fobituaries%2Farticle_f08040d8-94cf-11ec-84d0-8b847333e4b3.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"f08040d8-94cf-11ec-84d0-8b847333e4b3"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/obituaries/article_f08040d8-94cf-11ec-84d0-8b847333e4b3.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"f08040d8-94cf-11ec-84d0-8b847333e4b3"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-f08040d8-94cf-11ec-84d0-8b847333e4b3-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="f08040d8-94cf-11ec-84d0-8b847333e4b3" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="f08040d8-94cf-11ec-84d0-8b847333e4b3" class="save-list-f08040d8-94cf-11ec-84d0-8b847333e4b3-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="f08040d8-94cf-11ec-84d0-8b847333e4b3" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                <a href="/search/?k=%22baytown%22#tncms-source=keyword" class="tag-baytown label label-default" data-tncms-track-dmp='search: baytown'>Baytown</a>
            </li> <li>
                <a href="/search/?k=%22ernestine%20hunter%22#tncms-source=keyword" class="tag-ernestine-hunter label label-default" data-tncms-track-dmp='search: ernestine-hunter'>Ernestine Hunter</a>
            </li> <li>
                <a href="/search/?k=%22frazier%22#tncms-source=keyword" class="tag-frazier label label-default" data-tncms-track-dmp='search: frazier'>Frazier</a>
            </li> <li>
                <a href="/search/?k=%22christianity%22#tncms-source=keyword" class="tag-christianity label label-default" data-tncms-track-dmp='search: christianity'>Christianity</a>
            </li> <li>
                <a href="/search/?k=%22funeral%20service%22#tncms-source=keyword" class="tag-funeral-service label label-default" data-tncms-track-dmp='search: funeral-service'>Funeral Service</a>
            </li> <li>
                <a href="/search/?k=%22funeral%20home%22#tncms-source=keyword" class="tag-funeral-home label label-default" data-tncms-track-dmp='search: funeral-home'>Funeral Home</a>
            </li> <li>
                <a href="/search/?k=%22texas%22#tncms-source=keyword" class="tag-texas label label-default" data-tncms-track-dmp='search: texas'>Texas</a>
            </li> <li>
                <a href="/search/?k=%22viewing%22#tncms-source=keyword" class="tag-viewing label label-default" data-tncms-track-dmp='search: viewing'>Viewing</a>
            </li> </ul>
                        </div>
                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"><div id="tncms-block-1718534" class="tncms-block"><section id="block-1718534" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1718534 ">
        <div class="block-title-inner">
            <h3>
                
                Recommended for you
                
            </h3>
        </div>
    </div></div><div id="card-grid-behavioral-1718534" class="card-grid-behavioral card-grid card-img- card-compact"  data-lotame-track="true"><div class=" row equal equal-wrap"><div id="tncms-recommendations-1718534" class="recommendations-container"></div>
            <div class="clearfix hidden-xs"></div>
            </div>
        </div></section></div></div>

                    <div class="asset-comments hidden-print"></div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top","id":"fixed-big-ad-top","pos":"fixed-big-ad-top, atf","fold":"above","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/obituaries","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-top" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-top1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-top', slot: 1, fold: "above"});</script>

</div>
</div>
<div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-1505131" class="tncms-block baytown-eedition-block"><section id="block-1505131" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1505131 ">
        <div class="block-title-inner">
            <h4>
                
                Today's e-Edition
                
            </h4>
        </div>
    </div></div>
    
        <article id="card-summary-4b54e5ec-1ff9-5fbd-a539-869510fffb8f" class="clearfix card summary">
                <div class="card-container">
                        <div class="card-image">
                            <div class="media-preview-4b54e5ec-1ff9-5fbd-a539-869510fffb8f media-preview edition-asset " data-aspect=""><figure class="photo layout-vertical letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/eedition/edition_4b54e5ec-1ff9-5fbd-a539-869510fffb8f.html" class="tnt-asset-link"  aria-label="Baytown Sun">
                
                
                    <div class="asset-icon"><i class="far tnt-newspaper tnt-fw" title="e-Edition"></i></div>
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Baytown Sun"
                            class="img-responsive lazyload full default"
                            width="300"
                            height="629"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/eedition/a/b8/ab85f73e-b68c-551d-9b9b-8d811ab4d82f/621432501d368.preview-300.jpg?resize=150%2C315 150w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/eedition/a/b8/ab85f73e-b68c-551d-9b9b-8d811ab4d82f/621432501d368.preview-300.jpg?resize=200%2C419 200w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/eedition/a/b8/ab85f73e-b68c-551d-9b9b-8d811ab4d82f/621432501d368.preview-300.jpg?resize=225%2C472 225w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/eedition/a/b8/ab85f73e-b68c-551d-9b9b-8d811ab4d82f/621432501d368.preview-300.jpg?resize=300%2C629 300w" />
                </a>
                
            </div>
            
        </figure></div>
                        </div>
                    <div class="card-body">
                        <div class="card-headline">
                            <h3 class="tnt-headline ">
        
             <a href="/eedition/edition_4b54e5ec-1ff9-5fbd-a539-869510fffb8f.html" class="tnt-asset-link" aria-label="Baytown Sun">
        

        
            Baytown Sun</a></h3>
                        </div>
                            <div class="card-meta">
                                <ul class="list-inline">
                                    
                                    
                                        <li style="padding-bottom:10px;">To view our latest e-Edition click the image on the left.</li>
                                    </ul>
                            </div>
                    </div>
                </div>
                <div class="clearfix"></div>
            </article>
    
    </section></div><div id="tncms-block-1507223" class="tncms-block"><section id="block-1507223" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1507223 ">
        <div class="block-title-inner">
            <h4>
                
                Greater Baytown
                
            </h4>
        </div>
    </div></div>
    
        
            <div class="card-panel panel">
                <div class="panel-body">
        <article id="card-summary-cc7f5a7d-d94f-5819-81b4-995256f2d845" class="clearfix card summary">
                <div class="card-container">
                        <div class="card-image">
                            <div class="media-preview-cc7f5a7d-d94f-5819-81b4-995256f2d845 media-preview edition-asset " data-aspect=""><figure class="photo layout-vertical letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/magazines/greater_baytown/edition_cc7f5a7d-d94f-5819-81b4-995256f2d845.html" class="tnt-asset-link"  aria-label="Greater Baytown - February 2022">
                
                
                    <div class="asset-icon"><i class="far tnt-newspaper tnt-fw" title="e-Edition"></i></div>
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Greater Baytown - February 2022"
                            class="img-responsive lazyload full default"
                            width="300"
                            height="363"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/eedition/a/9d/a9d9896c-81d9-5de9-af25-84e11df40794/61f999c80e6e8.preview-300.jpg?resize=150%2C182 150w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/eedition/a/9d/a9d9896c-81d9-5de9-af25-84e11df40794/61f999c80e6e8.preview-300.jpg?resize=200%2C242 200w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/eedition/a/9d/a9d9896c-81d9-5de9-af25-84e11df40794/61f999c80e6e8.preview-300.jpg?resize=225%2C272 225w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/eedition/a/9d/a9d9896c-81d9-5de9-af25-84e11df40794/61f999c80e6e8.preview-300.jpg?resize=300%2C363 300w" />
                </a>
                
            </div>
            
        </figure></div>
                        </div>
                    <div class="card-body">
                        <div class="card-headline">
                            <h3 class="tnt-headline ">
        
             <a href="/magazines/greater_baytown/edition_cc7f5a7d-d94f-5819-81b4-995256f2d845.html" class="tnt-asset-link" aria-label="Greater Baytown - February 2022">
        

        
            Greater Baytown - February 2022</a></h3>
                        </div>
                            <div class="card-meta">
                                <ul class="list-inline">
                                    
                                    
                                        <li style="padding-bottom:10px;">To view our latest e-Edition click the image on the left.</li>
                                    </ul>
                            </div>
                    </div>
                </div>
                <div class="clearfix"></div>
            </article>
                </div>
            </div>
        
    
    </section></div><div id="tncms-block-1616401" class="tncms-block baytown-eedition-block"><section id="block-1616401" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1616401 ">
        <div class="block-title-inner">
            <h4>
                
                Chambers County Weekly
                
            </h4>
        </div>
    </div></div>
    
        <article id="card-summary-454040b0-83a2-598c-8872-5bc575c1047c" class="clearfix card summary">
                <div class="card-container">
                        <div class="card-image">
                            <div class="media-preview-454040b0-83a2-598c-8872-5bc575c1047c media-preview edition-asset " data-aspect=""><figure class="photo layout-vertical letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/magazines/chambers_county_weekly/edition_454040b0-83a2-598c-8872-5bc575c1047c.html" class="tnt-asset-link"  aria-label="Chambers County Weekly">
                
                
                    <div class="asset-icon"><i class="far tnt-newspaper tnt-fw" title="e-Edition"></i></div>
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Chambers County Weekly"
                            class="img-responsive lazyload full default"
                            width="300"
                            height="629"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/eedition/a/5d/a5d4c200-0797-561e-8732-b63f7a31cc7c/620da00a28422.preview-300.jpg?resize=150%2C315 150w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/eedition/a/5d/a5d4c200-0797-561e-8732-b63f7a31cc7c/620da00a28422.preview-300.jpg?resize=200%2C419 200w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/eedition/a/5d/a5d4c200-0797-561e-8732-b63f7a31cc7c/620da00a28422.preview-300.jpg?resize=225%2C472 225w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/eedition/a/5d/a5d4c200-0797-561e-8732-b63f7a31cc7c/620da00a28422.preview-300.jpg?resize=300%2C629 300w" />
                </a>
                
            </div>
            
        </figure></div>
                        </div>
                    <div class="card-body">
                        <div class="card-headline">
                            <h3 class="tnt-headline ">
        
             <a href="/magazines/chambers_county_weekly/edition_454040b0-83a2-598c-8872-5bc575c1047c.html" class="tnt-asset-link" aria-label="Chambers County Weekly">
        

        
            Chambers County Weekly</a></h3>
                        </div>
                            <div class="card-meta">
                                <ul class="list-inline">
                                    
                                    
                                        <li style="padding-bottom:10px;">To view our latest issue click the image on the left.</li>
                                    </ul>
                            </div>
                    </div>
                </div>
                <div class="clearfix"></div>
            </article>
    
    </section></div><div id="tncms-block-1536415" class="tncms-block hidden-xs hidden-sm">
        <div id="blox-ad-position-block-rightcol-top1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-rightcol-top","slot":"1","fold":"above","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1507225" class="tncms-block"></div><div id="tncms-block-1507226" class="tncms-block"></div><div id="tncms-block-1536416" class="tncms-block hidden-xs hidden-sm">
        <div id="blox-ad-position-block-rightcol-top21" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-rightcol-top2","slot":"1","fold":"above","width":"300","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1505056" class="tncms-block"><section id="block-1505056" class="block emphasis-h4 dark  " ><div class="clearfix">
    
    <div class="block-title title-1505056 ">
        <div class="block-title-inner">
            <h4>
                
                Obituaries
                
            </h4>
        </div>
    </div></div>
    
    <div class="card-img-sm card-bg-color card-compact">
        
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                
                <article id="card-summary-1505056-f08040d8-94cf-11ec-84d0-8b847333e4b3" class="tnt-asset-type-article clearfix card summary has-image image-left dark letterbox-style-default  tnt-section-obituaries">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-f08040d8-94cf-11ec-84d0-8b847333e4b3 media-preview article-asset " data-aspect="2:3"><figure class="photo layout-vertical letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/obituaries/article_f08040d8-94cf-11ec-84d0-8b847333e4b3.html" class="tnt-asset-link"  aria-label="Ernestine Hunter (Ms. Chat)">
                
                
                
                <img
                    alt="Ernestine Hunter (Ms. Chat)"
                    src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/6/e6/6e60f9b6-94d0-11ec-8bd9-fb2acd47c7fb/6216731025bf5.image.jpg"
                    class="img-responsive  letterbox default"
                    loading="lazy"
                    width="125"
                    height="188" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/obituaries/article_f08040d8-94cf-11ec-84d0-8b847333e4b3.html" class="tnt-asset-link" aria-label="Ernestine Hunter (Ms. Chat)">
        

        
            Ernestine Hunter (Ms. Chat)</a></h4></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-date">
        <time datetime="2022-02-23T11:42:00-06:00" class="tnt-date asset-date text-muted">11 hrs ago</time></li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
            
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                
                <article id="card-summary-1505056-de9ab4fe-94c8-11ec-b422-23bf182854c1" class="tnt-asset-type-article clearfix card summary has-image image-left dark letterbox-style-default  tnt-section-obituaries">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-de9ab4fe-94c8-11ec-b422-23bf182854c1 media-preview article-asset " data-aspect="2:3"><figure class="photo layout-vertical letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/obituaries/article_de9ab4fe-94c8-11ec-b422-23bf182854c1.html" class="tnt-asset-link"  aria-label="Alvin S. Pyle Jr.">
                
                
                
                <img
                    alt="Alvin S. Pyle Jr."
                    src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/4/e4/4e4ee8ce-94c9-11ec-8afd-3b006f665dae/621666fc2597a.image.jpg?resize=196%2C200"
                    class="img-responsive  letterbox default"
                    loading="lazy"
                    width="343"
                    height="515" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/obituaries/article_de9ab4fe-94c8-11ec-b422-23bf182854c1.html" class="tnt-asset-link" aria-label="Alvin S. Pyle Jr.">
        

        
            Alvin S. Pyle Jr.</a></h4></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-date">
        <time datetime="2022-02-23T10:51:00-06:00" class="tnt-date asset-date text-muted">12 hrs ago</time></li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
            
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                
                <article id="card-summary-1505056-6108e648-9363-11ec-9d40-1f5d3ee4823a" class="tnt-asset-type-article clearfix card summary has-image image-left dark letterbox-style-default  tnt-section-obituaries">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-6108e648-9363-11ec-9d40-1f5d3ee4823a media-preview article-asset " data-aspect="2:3"><figure class="photo layout-vertical letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/obituaries/article_6108e648-9363-11ec-9d40-1f5d3ee4823a.html" class="tnt-asset-link"  aria-label="Leandra Vasquez Martinez (Chita)">
                
                
                
                <img
                    alt="Leandra Vasquez Martinez (Chita)"
                    src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/3/be/3be8cbb6-9364-11ec-8138-ffa958f73748/6214100a9b870.image.jpg?resize=137%2C200"
                    class="img-responsive  letterbox default"
                    loading="lazy"
                    width="683"
                    height="1024" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/obituaries/article_6108e648-9363-11ec-9d40-1f5d3ee4823a.html" class="tnt-asset-link" aria-label="Leandra Vasquez Martinez (Chita)">
        

        
            Leandra Vasquez Martinez (Chita)</a></h4></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-date">
        <time datetime="2022-02-21T16:12:00-06:00" class="tnt-date asset-date text-muted">Feb 21, 2022</time></li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
            
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                
                <article id="card-summary-1505056-f8e0373c-933b-11ec-ac3c-df016f279b56" class="tnt-asset-type-article clearfix card summary has-image image-left dark letterbox-style-default  tnt-section-obituaries">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-f8e0373c-933b-11ec-ac3c-df016f279b56 media-preview article-asset " data-aspect="2:3"><figure class="photo layout-vertical letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/obituaries/article_f8e0373c-933b-11ec-ac3c-df016f279b56.html" class="tnt-asset-link"  aria-label="Robert Lee Jones">
                
                
                
                <img
                    alt="Robert Lee Jones"
                    src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/7/e2/7e20432e-933c-11ec-b9b2-5feb8de13c44/6213cd38a6e66.image.jpg?resize=159%2C200"
                    class="img-responsive  letterbox default"
                    loading="lazy"
                    width="333"
                    height="500" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/obituaries/article_f8e0373c-933b-11ec-ac3c-df016f279b56.html" class="tnt-asset-link" aria-label="Robert Lee Jones">
        

        
            Robert Lee Jones</a></h4></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-date">
        <time datetime="2022-02-21T11:30:00-06:00" class="tnt-date asset-date text-muted">Feb 21, 2022</time></li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
            </div></section></div><div id="tncms-block-1505068" class="tncms-block weekly-survey-block"><section id="block-1505068" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1505068 ">
        <div class="block-title-inner">
            <h4>
                
                Sun Weekly Survey
                
            </h4>
        </div>
    </div></div>
        
            
                <div class="poll-panel panel">
                    <div class="panel-body">
            
            <h4 class="tnt-headline ">
        
             <a href="/local/poll_9b9e9a48-9104-11ec-abf7-e7fa4d6542ec.html" class="tnt-asset-link" aria-label="For the March 1 Primary Election, Texans vote via mail, during early voting or on Election Day. How did you vote or plan to vote in the primary?">
        

        
            For the March 1 Primary Election, Texans vote via mail, during early voting or on Election Day. How did you vote or plan to vote in the primary?</a></h4>
            <div id="poll-9b9e9a48-9104-11ec-abf7-e7fa4d6542ec-1505068" data-charted="false" class="card poll-content"><div class="loading-poll hide-onload text-center"><i class="fas tnt-spinner tnt-spin tnt-2x"></i></div>
            <div class="show-onload">
                <div id="poll-9b9e9a48-9104-11ec-abf7-e7fa4d6542ec-1505068-your-vote-container" class="alert alert-warning hide">
                    <strong>You voted:</strong> <span id="poll-9b9e9a48-9104-11ec-abf7-e7fa4d6542ec-1505068-your-vote"></span>
                </div>
                <div id="poll-9b9e9a48-9104-11ec-abf7-e7fa4d6542ec-1505068-results" class="tnt-poll-results hide"></div>
                <div id="poll-9b9e9a48-9104-11ec-abf7-e7fa4d6542ec-1505068-container">
                    <form id="poll-9b9e9a48-9104-11ec-abf7-e7fa4d6542ec-1505068-form" class="tnt-poll-form" role="form" method="post" action="/local/poll_9b9e9a48-9104-11ec-abf7-e7fa4d6542ec.html">
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="Mail-in ballot" value="C9B74850-B470-0001-EB7CF5104CF58C20"> Mail-in ballot
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="During early voting" value="C9B74852-11E0-0001-636448D012ED7960"> During early voting
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="On primary Election Day" value="C9B74853-FD60-0001-9228BC40C219D2E0"> On primary Election Day
                                </label>
                            </div>
                        <div class="radio">
                                <label>
                                    <input type="radio" name="answer" title="Not at all" value="C9B74855-9FB0-0001-FDC91D6025841461"> Not at all
                                </label>
                            </div>
                        
                        <button type="submit" class="btn btn-primary" >Vote</button>
                        <button id="poll-9b9e9a48-9104-11ec-abf7-e7fa4d6542ec-1505068-get-results" class="btn btn-default" >View Results</button>
                    </form>
                </div>
            </div>
            <div id="poll-9b9e9a48-9104-11ec-abf7-e7fa4d6542ec-1505068-back-vote" class="padding-top hide">
                <button id="poll-9b9e9a48-9104-11ec-abf7-e7fa4d6542ec-1505068-back-btn" class="btn btn-default">Back</button>
            </div>
        </div>
            
                    </div>
                </div>
            
        
    </section></div><div id="tncms-block-1505149" class="tncms-block"><section id="block-1505149" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1505149 ">
        <div class="block-title-inner">
            <h4>
                
                    <a href="/newsletters">
                
                Sign Up For Newsletters
                
                    </a>
                
            </h4>
        </div>
    </div></div><div class=""><div class="card email-signup">
        <div class="alert alert-success" role="alert" style="display:none;">
            <p>
                <strong>Success!</strong> An email has been sent to <strong><span class="user-email"></span></strong> with a link to confirm list signup.
            </p>
        </div>
        <div class="alert alert-danger" role="alert" style="display:none;">
            <p>
                <strong>Error!</strong> There was an error processing your request.
            </p>
        </div>
        
            <div class="mailinglist-container">
                <div class="form-group ">
                    
                        <div class="mailinglist-item">
                            <h4 class="mailinglist-title">News Updates</h4>
                            
                                <p><span>Would you like to receive our daily news?&nbsp;</span><strong>Signup today!</strong></p>
                            
                        </div>
                    
                </div>
                <div class="form-group">
                    <a href="https://baytownsun.com/users/admin/mailinglist/" class="btn btn-default btn-block">Manage your lists</a>
                </div>
            </div>
        
    </div></div></section></div><div id="tncms-block-1505046" class="tncms-block visible-lg visible-md latest-news-block"><section id="block-1505046" class="block emphasis-h4 dark  " ><div class="clearfix">
    
    <div class="block-title title-1505046 ">
        <div class="block-title-inner">
            <h4>
                
                Latest News
                
            </h4>
        </div>
    </div></div>
    <div class=" card-bg-color"><div class="card-panel panel">
            <div class="panel-body"><ul class="card headline-list bullet-square border border-dashed"><li class="">
            <span class="tnt-headline ">
        
             <a href="/sports/article_18a7973c-9462-11ec-a655-83bcab95acd7.html" class="tnt-asset-link" aria-label="Patriots hang on, stave off Eagles threat">
        

        
            Patriots hang on, stave off Eagles threat</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/sports/article_72d88db0-94e9-11ec-81bc-73b7a511182e.html" class="tnt-asset-link" aria-label="GCM, REL boys soccer keep district-leading pace">
        

        
            GCM, REL boys soccer keep district-leading pace</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/sports/article_b2a59e88-94e9-11ec-b6d6-97538715cbaf.html" class="tnt-asset-link" aria-label="RSS softball defeats REL">
        

        
            RSS softball defeats REL</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/local/article_e8caa82c-94d1-11ec-bd32-77078d7086c9.html" class="tnt-asset-link" aria-label="Dogs kill Baytown 4-year-old">
        

        
            Dogs kill Baytown 4-year-old</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/sports/article_92d89fec-94e9-11ec-b3c2-1f4e34fef1ff.html" class="tnt-asset-link" aria-label="GCM wins opener, REL falls">
        

        
            GCM wins opener, REL falls</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/sports/article_23a22756-94e9-11ec-bfa2-6bb5a2470c43.html" class="tnt-asset-link" aria-label="They remain Xcel-lent">
        

        
            They remain Xcel-lent</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/article_8c6b6872-939c-11ec-bb52-33ea18f64824.html" class="tnt-asset-link" aria-label="Inaugural Gander alumni game raises $5K for program">
        

        
            Inaugural Gander alumni game raises $5K for program</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/article_5f32e84e-939c-11ec-b4b8-afc2735e11c9.html" class="tnt-asset-link" aria-label="Ready to tee off? Golf course on council agenda">
        

        
            Ready to tee off? Golf course on council agenda</a></span>
        </li></ul></div>
        </div></div></section></div><div id="tncms-block-1871505" class="tncms-block">
</div><div id="tncms-block-1505085" class="tncms-block most-popular-block"><section id="block-1505085" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1505085 ">
        <div class="block-title-inner">
            <h4>
                
                Popular BaytownSun Stories
                
            </h4>
        </div>
    </div></div><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-1505085" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
            <li >
                <a href="#images-1505085" data-toggle="tab"><i class="far tnt-image" title="images"></i><span class="tab-text"> Images</span></a>
            </li>
        
        
            <li >
                <a href="#videos-1505085" data-toggle="tab"><i class="fas tnt-play-circle" title="Videos"></i><span class="tab-text"> Videos</span></a>
            </li>
        
        
        
        
            <li >
                <a href="#commented-1505085" data-toggle="tab"><i class="far tnt-comments" title="Commented"></i><span class="tab-text"> Commented</span></a>
            </li>
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-1505085" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-disc "><li><a href="/obituaries/article_5bc7151c-8f79-11ec-ac1d-438f6cdab45a.html">Brittani Elizabeth Rombs</a></li><li><a href="/obituaries/article_f8e0373c-933b-11ec-ac3c-df016f279b56.html">Robert Lee Jones</a></li><li><a href="/local/article_e8caa82c-94d1-11ec-bd32-77078d7086c9.html">Dogs kill Baytown 4-year-old</a></li><li><a href="/news/article_b2c47d5a-8f92-11ec-aa26-c36696bc4af0.html">Trial of fired BPD officer gets underway</a></li><li><a href="/obituaries/article_5dd642f6-9109-11ec-a8d6-731274ba05a7.html">Donna S. Bruce R.N.</a></li><li><a href="/obituaries/article_b7e1ee7a-8f75-11ec-bf7c-cb80680437df.html">David Lee Black</a></li><li><a href="/news/article_8c6b6872-939c-11ec-bb52-33ea18f64824.html">Inaugural Gander alumni game raises $5K for program</a></li><li><a href="/local/article_754833c2-838a-11ec-8466-efc641316abb.html">Black History Month - Where would this world be without the Black Men & Black Women?</a></li><li><a href="/news/police/article_b8a3f396-939c-11ec-a64d-afd0a11060a0.html">Police Beat: Woman killed crossing freeway</a></li><li><a href="/sports/article_5fa6adce-91df-11ec-bc9a-af00c761f758.html">GC teams expect playoff pushes</a></li></ul></div>
        
        
            <div id="images-1505085" class="tab-pane tab-pane-images fade in ">
                <h4 class="tab-content-heading">Images</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/image_508042b8-838b-11ec-97b5-e75d376dfb9c.html" class="tnt-asset-link"  aria-label="Charles B. Brooks">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Charles B. Brooks"
                            class="img-responsive lazyload full default"
                            width="141"
                            height="141"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/5/08/508042b8-838b-11ec-97b5-e75d376dfb9c/61f9796390954.image.jpg?crop=141%2C141%2C0%2C13&resize=141%2C141&order=crop%2Cresize" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/image_8eacfe74-806a-11ec-b340-b743c53a46e7.html" class="tnt-asset-link"  aria-label="Lawrence Harvey Shelton">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Lawrence Harvey Shelton"
                            class="img-responsive lazyload full default"
                            width="1176"
                            height="1176"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/8/ea/8eacfe74-806a-11ec-b340-b743c53a46e7/61f43a14b5c7f.image.jpg?crop=1176%2C1176%2C0%2C293&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/8/ea/8eacfe74-806a-11ec-b340-b743c53a46e7/61f43a14b5c7f.image.jpg?crop=1176%2C1176%2C0%2C293&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/8/ea/8eacfe74-806a-11ec-b340-b743c53a46e7/61f43a14b5c7f.image.jpg?crop=1176%2C1176%2C0%2C293&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/8/ea/8eacfe74-806a-11ec-b340-b743c53a46e7/61f43a14b5c7f.image.jpg?crop=1176%2C1176%2C0%2C293&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/8/ea/8eacfe74-806a-11ec-b340-b743c53a46e7/61f43a14b5c7f.image.jpg?crop=1176%2C1176%2C0%2C293&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/8/ea/8eacfe74-806a-11ec-b340-b743c53a46e7/61f43a14b5c7f.image.jpg?crop=1176%2C1176%2C0%2C293&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/8/ea/8eacfe74-806a-11ec-b340-b743c53a46e7/61f43a14b5c7f.image.jpg?crop=1176%2C1176%2C0%2C293&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/8/ea/8eacfe74-806a-11ec-b340-b743c53a46e7/61f43a14b5c7f.image.jpg?crop=1176%2C1176%2C0%2C293&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/8/ea/8eacfe74-806a-11ec-b340-b743c53a46e7/61f43a14b5c7f.image.jpg?crop=1176%2C1176%2C0%2C293&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/8/ea/8eacfe74-806a-11ec-b340-b743c53a46e7/61f43a14b5c7f.image.jpg?crop=1176%2C1176%2C0%2C293&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/8/ea/8eacfe74-806a-11ec-b340-b743c53a46e7/61f43a14b5c7f.image.jpg?crop=1176%2C1176%2C0%2C293&resize=1176%2C1176&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/image_a898a0b4-939c-11ec-8fa4-df5311b4b892.html" class="tnt-asset-link"  aria-label="Inaugural Gander alumni game raises $5K for program">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Inaugural Gander alumni game raises $5K for program"
                            class="img-responsive lazyload full default"
                            width="315"
                            height="315"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/a/89/a898a0b4-939c-11ec-8fa4-df5311b4b892/62146e856c0ae.image.jpg?crop=315%2C315%2C287%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/a/89/a898a0b4-939c-11ec-8fa4-df5311b4b892/62146e856c0ae.image.jpg?crop=315%2C315%2C287%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/a/89/a898a0b4-939c-11ec-8fa4-df5311b4b892/62146e856c0ae.image.jpg?crop=315%2C315%2C287%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/a/89/a898a0b4-939c-11ec-8fa4-df5311b4b892/62146e856c0ae.image.jpg?crop=315%2C315%2C287%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/a/89/a898a0b4-939c-11ec-8fa4-df5311b4b892/62146e856c0ae.image.jpg?crop=315%2C315%2C287%2C0&resize=315%2C315&order=crop%2Cresize 400w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/image_50257b4e-838b-11ec-b74c-23d283529553.html" class="tnt-asset-link"  aria-label="Alfred L. Cralle">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Alfred L. Cralle"
                            class="img-responsive lazyload full default"
                            width="141"
                            height="141"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/5/02/50257b4e-838b-11ec-b74c-23d283529553/61f97962f37a0.image.jpg?crop=141%2C141%2C0%2C5&resize=141%2C141&order=crop%2Cresize" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/image_2f5ee4b6-8a09-11ec-9c8c-9b7aa7dac86b.html" class="tnt-asset-link"  aria-label="BLT">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="BLT"
                            class="img-responsive lazyload full default"
                            width="1175"
                            height="1175"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/2/f5/2f5ee4b6-8a09-11ec-9c8c-9b7aa7dac86b/62045de46840e.image.jpg?crop=1175%2C1175%2C294%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/2/f5/2f5ee4b6-8a09-11ec-9c8c-9b7aa7dac86b/62045de46840e.image.jpg?crop=1175%2C1175%2C294%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/2/f5/2f5ee4b6-8a09-11ec-9c8c-9b7aa7dac86b/62045de46840e.image.jpg?crop=1175%2C1175%2C294%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/2/f5/2f5ee4b6-8a09-11ec-9c8c-9b7aa7dac86b/62045de46840e.image.jpg?crop=1175%2C1175%2C294%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/2/f5/2f5ee4b6-8a09-11ec-9c8c-9b7aa7dac86b/62045de46840e.image.jpg?crop=1175%2C1175%2C294%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/2/f5/2f5ee4b6-8a09-11ec-9c8c-9b7aa7dac86b/62045de46840e.image.jpg?crop=1175%2C1175%2C294%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/2/f5/2f5ee4b6-8a09-11ec-9c8c-9b7aa7dac86b/62045de46840e.image.jpg?crop=1175%2C1175%2C294%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/2/f5/2f5ee4b6-8a09-11ec-9c8c-9b7aa7dac86b/62045de46840e.image.jpg?crop=1175%2C1175%2C294%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/2/f5/2f5ee4b6-8a09-11ec-9c8c-9b7aa7dac86b/62045de46840e.image.jpg?crop=1175%2C1175%2C294%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/2/f5/2f5ee4b6-8a09-11ec-9c8c-9b7aa7dac86b/62045de46840e.image.jpg?crop=1175%2C1175%2C294%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/2/f5/2f5ee4b6-8a09-11ec-9c8c-9b7aa7dac86b/62045de46840e.image.jpg?crop=1175%2C1175%2C294%2C0&resize=1175%2C1175&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/image_d7b7c9ae-910a-11ec-b86a-3f719b9cc3dc.html" class="tnt-asset-link"  aria-label="Trevia Wooster Beverly">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Trevia Wooster Beverly"
                            class="img-responsive lazyload full default"
                            width="179"
                            height="179"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/d/7b/d7b7c9ae-910a-11ec-b86a-3f719b9cc3dc/62101f15d2970.image.png?crop=179%2C179%2C0%2C11&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/assets/v3/editorial/d/7b/d7b7c9ae-910a-11ec-b86a-3f719b9cc3dc/62101f15d2970.image.png?crop=179%2C179%2C0%2C11&resize=179%2C179&order=crop%2Cresize 200w" />
                </a>
                
            </div>
            
        </figure></li>
                        </ul></div>
        
        <div id="videos-1505085" class="tab-pane tab-pane-videos fade in ">
                <h4 class="tab-content-heading">Videos</h4><p class="no-results text-muted">Sorry, there are no recent results for popular videos.</p></div>
        
        
        
        
            <div id="commented-1505085" class="tab-pane tab-pane-commented fade in ">
                <h4 class="tab-content-heading">Commented</h4><ul class="tab-content-list bullet-disc "><li><a href="/opinion/letters/article_0a282e9e-7d95-11ec-b44c-7f1ed2aa8a3f.html">How much worse can this get?</a> (2)</li><li><a href="/opinion/letters/article_1c68b4d8-8895-11ec-9bd6-cb81ecf51a5e.html">Nation heading in wrong direction</a> (2)</li><li><a href="/opinion/letters/article_3705a2e0-9107-11ec-b431-5fe06a4f54ed.html">Benefits to meat-free Lent</a> (2)</li><li><a href="/news/article_6d81a92c-8b94-11ec-8318-e7d6da4f6019.html">Council awards contracts for Texas Ave. bank project</a> (2)</li><li><a href="/opinion/letters/article_76a74a7c-830e-11ec-9163-4f18b7596c6a.html">Make your 2022 votes count</a> (2)</li><li><a href="/opinion/columns/article_0e79debe-8b89-11ec-8a0a-03af18f8b64a.html">‘Trying to set a diamond into a Mickey Mouse watch’</a> (1)</li><li><a href="/local/article_0f371f0a-8a0e-11ec-9c3c-97c1002e3e95.html">City not ready to tee up golf course vote yet; developer's plan released</a> (1)</li><li><a href="/news/article_30fa2250-8620-11ec-90c4-b3c0dd0cd8b3.html">Bayland hotel project costs climb $6.3 million</a> (1)</li><li><a href="/opinion/letters/article_35d22ae4-8895-11ec-ad91-97ef8378dec7.html">Whitewashing history</a> (1)</li><li><a href="/news/police/article_3bb9d412-7d95-11ec-9c82-43992e57b7cb.html">Police Beat: Woman robbed at gunpoint</a> (1)</li><li><a href="/opinion/letters/article_416c94bc-7f07-11ec-bf37-3b82ffcf616c.html">Surviving in spite of Biden</a> (1)</li><li><a href="/news/article_4cba2674-8310-11ec-9667-6be5d6df178f.html">Guns, drugs seized in bust</a> (1)</li><li><a href="/opinion/letters/article_51166a26-8481-11ec-8b5d-fbb88206702b.html">This group must go</a> (1)</li><li><a href="/opinion/letters/article_51cfed44-830e-11ec-bb2f-8fb6ab186ffb.html">Councilman 'cautiously optimistic' about mall talks</a> (1)</li><li><a href="/news/article_a60bebb6-911d-11ec-984d-7776ccd5114b.html">Pct. 2 lays out regional plans</a> (1)</li><li><a href="/pdf_d4879d8e-8a86-11ec-9da9-0fecdaee7852.html">Miramar Properties plan for Baytown golf course</a> (1)</li><li><a href="/news/article_db0e433a-8895-11ec-bf68-9f8a91aedbad.html">Work begins again on Goose Creek Trail</a> (1)</li><li><a href="/opinion/letters/article_f29a5796-8b88-11ec-b3c9-3bd117912167.html">Not responsible governing</a> (1)</li></ul></div>
        
    </div>
</div></section></div><div id="tncms-block-1880979" class="tncms-block"><section id="block-1880979" class="block emphasis-h3   " ><div id="evvnt-calendar-1880979"></div>
<script defer src="//production-evvnt-plugin-herokuapp-com.global.ssl.fastly.net/evvnt_discovery_plugin_s.js" onload="evvntDiscoveryInit_1880979();"></script></section></div><div id="tncms-block-1507236" class="tncms-block"><section id="block-1507236" class="block emphasis-h4 dark  " ><div class="clearfix">
    
    <div class="block-title title-1507236 dark">
        <div class="block-title-inner">
            <h4>
                
                    <a href="/opinion/letters">
                
                Letters to the Editor
                
                    </a>
                
            </h4>
        </div>
    </div></div>
    
    <div class="card-img-sm card-bg-color card-compact">
        
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                
                <article id="card-summary-1507236-3705a2e0-9107-11ec-b431-5fe06a4f54ed" class="tnt-asset-type-article clearfix card summary dark letterbox-style-default  tnt-section-opinion tnt-sub-section-letters">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/opinion/letters/article_3705a2e0-9107-11ec-b431-5fe06a4f54ed.html" class="tnt-asset-link" aria-label="Benefits to meat-free Lent">
        

        
            Benefits to meat-free Lent</a></h4></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-date">
        <time datetime="2022-02-19T00:00:00-06:00" class="tnt-date asset-date text-muted">Feb 19, 2022</time></li><li class="card-comment-count"></li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
            
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                
                <article id="card-summary-1507236-4fb72804-9107-11ec-b314-d7e11d235e4d" class="tnt-asset-type-article clearfix card summary dark letterbox-style-default  tnt-section-opinion tnt-sub-section-letters">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/opinion/letters/article_4fb72804-9107-11ec-b314-d7e11d235e4d.html" class="tnt-asset-link" aria-label="Community has supported local homelessness efforts for years">
        

        
            Community has supported local homelessness efforts for years</a></h4></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-date">
        <time datetime="2022-02-19T00:00:00-06:00" class="tnt-date asset-date text-muted">Feb 19, 2022</time></li><li class="card-comment-count"></li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
            
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                
                <article id="card-summary-1507236-6419e0f2-9107-11ec-96f4-53cb1b9c3d13" class="tnt-asset-type-article clearfix card summary dark letterbox-style-default  tnt-section-opinion tnt-sub-section-letters">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/opinion/letters/article_6419e0f2-9107-11ec-96f4-53cb1b9c3d13.html" class="tnt-asset-link" aria-label="Thank you, Baytown">
        

        
            Thank you, Baytown</a></h4></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-date">
        <time datetime="2022-02-19T00:00:00-06:00" class="tnt-date asset-date text-muted">Feb 19, 2022</time></li><li class="card-comment-count"></li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
            
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                
                <article id="card-summary-1507236-f29a5796-8b88-11ec-b3c9-3bd117912167" class="tnt-asset-type-article clearfix card summary dark letterbox-style-default  tnt-section-opinion tnt-sub-section-letters">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/opinion/letters/article_f29a5796-8b88-11ec-b3c9-3bd117912167.html" class="tnt-asset-link" aria-label="Not responsible governing">
        

        
            Not responsible governing</a></h4></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-date">
        <time datetime="2022-02-12T00:00:00-06:00" class="tnt-date asset-date text-muted">Feb 12, 2022</time></li><li class="card-comment-count"></li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
            
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                
                <article id="card-summary-1507236-1eeb8270-89ea-11ec-8877-77fa0b0a336a" class="tnt-asset-type-article clearfix card summary dark letterbox-style-default  tnt-section-opinion tnt-sub-section-letters">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/opinion/letters/article_1eeb8270-89ea-11ec-8877-77fa0b0a336a.html" class="tnt-asset-link" aria-label="Additional step for mail ballots">
        

        
            Additional step for mail ballots</a></h4></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-date">
        <time datetime="2022-02-10T00:00:00-06:00" class="tnt-date asset-date text-muted">Feb 10, 2022</time></li><li class="card-comment-count"></li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
            
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                
                <article id="card-summary-1507236-1c68b4d8-8895-11ec-9bd6-cb81ecf51a5e" class="tnt-asset-type-article clearfix card summary dark letterbox-style-default  tnt-section-opinion tnt-sub-section-letters">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/opinion/letters/article_1c68b4d8-8895-11ec-9bd6-cb81ecf51a5e.html" class="tnt-asset-link" aria-label="Nation heading in wrong direction">
        

        
            Nation heading in wrong direction</a></h4></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-date">
        <time datetime="2022-02-08T00:00:00-06:00" class="tnt-date asset-date text-muted">Feb 8, 2022</time></li><li class="card-comment-count"></li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
            
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                
                <article id="card-summary-1507236-35d22ae4-8895-11ec-ad91-97ef8378dec7" class="tnt-asset-type-article clearfix card summary dark letterbox-style-default  tnt-section-opinion tnt-sub-section-letters">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/opinion/letters/article_35d22ae4-8895-11ec-ad91-97ef8378dec7.html" class="tnt-asset-link" aria-label="Whitewashing history">
        

        
            Whitewashing history</a></h4></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-date">
        <time datetime="2022-02-08T00:00:00-06:00" class="tnt-date asset-date text-muted">Feb 8, 2022</time></li><li class="card-comment-count"></li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
            
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                
                <article id="card-summary-1507236-485dcb28-8895-11ec-a782-2310719a14b4" class="tnt-asset-type-article clearfix card summary dark letterbox-style-default  tnt-section-opinion tnt-sub-section-letters">
            <div class="card-container">
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/opinion/letters/article_485dcb28-8895-11ec-a782-2310719a14b4.html" class="tnt-asset-link" aria-label="City loves to spend money">
        

        
            City loves to spend money</a></h4></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-date">
        <time datetime="2022-02-08T00:00:00-06:00" class="tnt-date asset-date text-muted">Feb 8, 2022</time></li><li class="card-comment-count"></li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
            </div>
        <ul class="list-inline block-links pos-bottom ">
            
                
                    <li><a href="/opinion/letters" class="">Opinion columns</a></li>
                
            
            
        </ul></section></div><div id="tncms-block-1505094" class="tncms-block"><section id="block-1505094" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1505094 ">
        <div class="block-title-inner">
            <h3>
                
                    <a href="http://baytownsun.com/news/milestones/article_3c23552c-3b9b-11e7-8b70-9b91fd1b53dc.html">
                
                Milestones
                
                    </a>
                
            </h3>
        </div>
    </div></div><article class="card promo media"><div class="media-body"><p><strong>Birthday wishes</strong>
<p>Call 281-422-8302 or email david.bloom@baytownsun.com to wish someone a happy birthday. We will print your birthday wish on Page 2 of The Sun.</p></p><a href="http://baytownsun.com/news/milestones/article_3c23552c-3b9b-11e7-8b70-9b91fd1b53dc.html">
                <button type="button" class="btn btn-primary  ">Happy Birthday Wishes</button>
            </a></div>
</article></section></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle","id":"fixed-big-ad-middle","pos":"fixed-big-ad-middle, stf","fold":"span","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/obituaries","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-middle" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-middle1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-middle', slot: 1, fold: "span"});</script>

</div>
</div>
<div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-1505064" class="tncms-block"></div><div id="tncms-block-1505122" class="tncms-block"><section id="block-1505122" class="block emphasis-h4 light  " ><div class="clearfix">
    
    <div class="block-title title-1505122 ">
        <div class="block-title-inner">
            <h4>
                
                Top Ads
                
            </h4>
        </div>
    </div></div>
    
    <div class="card-img-md card-bg-color">
    
    
        
            <div class="card-panel panel">
                <div class="panel-body">
        
        
        <article id="card-product-4f356c77-d33b-59eb-98c6-03dce858239b" class="clearfix card  product " data-track-object='{"title":"For Sale by Owner: 504 Park St.","url":"/classifieds/real_estate/homes_for_sale/ad_4f356c77-d33b-59eb-98c6-03dce858239b.html","uuid":"4f356c77-d33b-59eb-98c6-03dce858239b","app":"classifieds","metric":""}' data-tncms-tracking="classifieds/featured/4f356c77-d33b-59eb-98c6-03dce858239b">
            <div class="card-container ">
                
                <div class="card-body">
                    
                    <div class="card-headline">
                        <h4 class="tnt-headline ">
        
             <a href="/classifieds/real_estate/homes_for_sale/ad_4f356c77-d33b-59eb-98c6-03dce858239b.html" class="tnt-asset-link" aria-label="For Sale by Owner: 504 Park St.">
        

        
            For Sale by Owner: 504 Park St.</a></h4>
                    </div>
                    

                    
                        
                        
                    

                    

                    
                        <div class="card-meta">
                            <ul class="list-inline">
                                
                                    <li class="text-muted"><i class="fas tnt-tag tnt-fw" title="Classified ad"></i></li>
                                
                                
                                
                                    
                                        <li class="card-date">
        <time datetime="2022-02-20T00:00:00-06:00" class="tnt-date asset-date text-muted">Feb 20, 2022</time></li>
                                    
                                
                                
                            </ul>
                        </div>
                    

                    
                    

                    

                    

                    
                    
                    
                    
                    

                    </div>
            </div>
        </article>
        
                </div>
            </div>
        
    
        
            <div class="card-panel panel">
                <div class="panel-body">
        
        
        <article id="card-product-d653a9ba-0c73-5e42-93a0-da4c4cf59014" class="clearfix card  product " data-track-object='{"title":"Experienced Auto Technician needed.","url":"/classifieds/employment/full-time_employment/ad_d653a9ba-0c73-5e42-93a0-da4c4cf59014.html","uuid":"d653a9ba-0c73-5e42-93a0-da4c4cf59014","app":"classifieds","metric":""}' data-tncms-tracking="classifieds/featured/d653a9ba-0c73-5e42-93a0-da4c4cf59014">
            <div class="card-container ">
                
                <div class="card-body">
                    
                    <div class="card-headline">
                        <h4 class="tnt-headline ">
        
             <a href="/classifieds/employment/full-time_employment/ad_d653a9ba-0c73-5e42-93a0-da4c4cf59014.html" class="tnt-asset-link" aria-label="Experienced Auto Technician needed.">
        

        
            Experienced Auto Technician needed.</a></h4>
                    </div>
                    

                    
                        
                        
                    

                    

                    
                        <div class="card-meta">
                            <ul class="list-inline">
                                
                                    <li class="text-muted"><i class="fas tnt-tag tnt-fw" title="Classified ad"></i></li>
                                
                                
                                
                                    
                                        <li class="card-date">
        <time datetime="2022-02-20T00:00:00-06:00" class="tnt-date asset-date text-muted">Feb 20, 2022</time></li>
                                    
                                
                                
                            </ul>
                        </div>
                    

                    
                    

                    

                    

                    
                    
                    
                    
                    

                    </div>
            </div>
        </article>
        
                </div>
            </div>
        
    
        
            <div class="card-panel panel">
                <div class="panel-body">
        
        
        <article id="card-product-209ad279-258b-576e-9f5c-fee33ee89d48" class="clearfix card  product " data-track-object='{"title":"No Title, No VIN, Bonded title","url":"/classifieds/automotive/cars/ad_209ad279-258b-576e-9f5c-fee33ee89d48.html","uuid":"209ad279-258b-576e-9f5c-fee33ee89d48","app":"classifieds","metric":""}' data-tncms-tracking="classifieds/featured/209ad279-258b-576e-9f5c-fee33ee89d48">
            <div class="card-container ">
                
                <div class="card-body">
                    
                    <div class="card-headline">
                        <h4 class="tnt-headline ">
        
             <a href="/classifieds/automotive/cars/ad_209ad279-258b-576e-9f5c-fee33ee89d48.html" class="tnt-asset-link" aria-label="No Title, No VIN, Bonded title">
        

        
            No Title, No VIN, Bonded title</a></h4>
                    </div>
                    
                        <div class="card-headline">
                            <h2 class="text-primary"><span class="asset-price">$1</span>
        </h2>
                        </div>
                    

                    
                        
                        
                    

                    

                    
                        <div class="card-meta">
                            <ul class="list-inline">
                                
                                    <li class="text-muted"><i class="fas tnt-tag tnt-fw" title="Classified ad"></i></li>
                                
                                
                                
                                    
                                        <li class="card-date">
        <time datetime="2022-02-17T00:00:00-06:00" class="tnt-date asset-date text-muted">Feb 17, 2022</time></li>
                                    
                                
                                
                            </ul>
                        </div>
                    

                    
                    

                    

                    

                    
                    
                    
                    
                    

                    </div>
            </div>
        </article>
        
                </div>
            </div>
        
    
    </div>
    </section></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom","id":"fixed-big-ad-bottom","pos":"fixed-big-ad-bottom, btf","fold":"below","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/obituaries","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-bottom" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-bottom1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-bottom', slot: 1, fold: "below"});</script>

</div>
</div>
<div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-1505028" class="tncms-block visible-xs visible-sm">
        <div id="blox-ad-position-block-leaderboard-bottom-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom-mobile","slot":"1","fold":"below","width":"320","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-1505027" class="tncms-block hidden-xs">
        <div id="blox-ad-position-block-leaderboard-bottom1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom","slot":"1","fold":"below","width":"728","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "><div id="tncms-block-1871508" class="tncms-block">
</div></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-1505125" class="tncms-block footer-block-titles"><section id="block-1505125" class="block emphasis-h1   " ><div class="clearfix">
    
    <div class="block-title title-1505125 ">
        <div class="block-title-inner">
            <h1>
                
                Sections
                
            </h1>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link    tnt-section-news"  href="/news"  tabindex="0" >
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link    tnt-section-sports"  href="/sports"  tabindex="0" >
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link    tnt-section-opinion"  href="/opinion"  tabindex="0" >
                    <span class="nav-label">Opinion</span>
                </a></li><li>
                <a class="nav-link    tnt-section-lifestyle"  href="/lifestyle/"  tabindex="0" >
                    <span class="nav-label">Lifestyle</span>
                </a></li><li>
                <a class="nav-link    tnt-section-communities"  href="/communities"  tabindex="0" >
                    <span class="nav-label">Communities</span>
                </a></li><li>
                <a class="nav-link    tnt-section-obituaries"  href="/obituaries"  tabindex="0" >
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link    tnt-section-entertainment"  href="/entertainment"  tabindex="0" >
                    <span class="nav-label">Entertainment</span>
                </a></li><li>
                <a class="nav-link    tnt-section-local-events"  href="/local-events/"  tabindex="0" >
                    <span class="nav-label">Local Events</span>
                </a></li><li>
                <a class="nav-link    tnt-section-multimedia"  href="/multimedia/"  tabindex="0" >
                    <span class="nav-label">Multimedia</span>
                </a></li><li>
                <a class="nav-link    tnt-section-weather"  href="/weather"  tabindex="0" >
                    <span class="nav-label">Weather</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-1505076" class="tncms-block footer-block-titles"><section id="block-1505076" class="block emphasis-h1   " ><div class="clearfix">
    
    <div class="block-title title-1505076 ">
        <div class="block-title-inner">
            <h1>
                
                Services
                
            </h1>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link    tnt-section-subscription-services"  href="/site/forms/subscription_services"  tabindex="0" >
                    <span class="nav-label">Subscription Services</span>
                </a></li><li>
                <a class="nav-link    tnt-section-submission-forms"  href="/site/forms"  tabindex="0" >
                    <span class="nav-label">Submission Forms</span>
                </a></li><li>
                <a class="nav-link    tnt-section-about-us"  href="/site/history.html"  tabindex="0" >
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link    tnt-section-place-an-ad"  href="/site/forms/online_services/classified"  tabindex="0" >
                    <span class="nav-label">Place an Ad</span>
                </a></li><li>
                <a class="nav-link    tnt-section-promote-your-event"  href="https://new.evvnt.com/?with_navbar&amp;force_snap_sell&amp;partner=BAYTOWNSUN&amp;publisher_url:baytownsun.com#/quick"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label">Promote Your Event</span>
                </a></li><li>
                <a class="nav-link    tnt-section-newsstand-locations"  href="/site/locations.html"  tabindex="0" >
                    <span class="nav-label">Newsstand Locations</span>
                </a></li><li>
                <a class="nav-link    tnt-section-pay-subscription-online"  href="/site/forms/subscription_services/pay_subscription_online/"  tabindex="0" >
                    <span class="nav-label">Pay Subscription Online</span>
                </a></li><li>
                <a class="nav-link    tnt-section-pay-advertising-invoice"  href="https://baytownsun.snibilling.com"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label">Pay Advertising Invoice</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-1534699" class="tncms-block padding-top"><div class="follow-links-1534699 default">
    
    <section id="block-1534699" class="block emphasis-h4   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/BaytownSun" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/thebaytownsun" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
            <li>
                <a href="https://www.instagram.com/thebaytownsun/" title="Instagram" target="_blank" rel="noopener" class="btn btn-md btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://baytownsun.com",
  "sameAs" : ["https://www.facebook.com/BaytownSun","https://twitter.com/thebaytownsun","https://www.instagram.com/thebaytownsun/"]
}
</script>
<div class="clearfix"></div></div><div id="tncms-block-1505130" class="tncms-block padding-bottom"><section id="block-1505130" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow"  >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/6eb09e78-9046-11ec-b140-570a7a23cd65.png?resize=150%2C21 150w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/6eb09e78-9046-11ec-b140-570a7a23cd65.png?resize=200%2C28 200w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/6eb09e78-9046-11ec-b140-570a7a23cd65.png?resize=225%2C31 225w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/6eb09e78-9046-11ec-b140-570a7a23cd65.png?resize=300%2C41 300w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/6eb09e78-9046-11ec-b140-570a7a23cd65.png?resize=400%2C55 400w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/6eb09e78-9046-11ec-b140-570a7a23cd65.png?resize=540%2C74 540w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/6eb09e78-9046-11ec-b140-570a7a23cd65.png?resize=640%2C88 640w, https://bloximages.chicago2.vip.townnews.com/baytownsun.com/content/tncms/custom/image/6eb09e78-9046-11ec-b140-570a7a23cd65.png 750w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="660"
                height="91"
                alt=""
                aria-hidden="true"></a></div></section></div><div id="tncms-block-1505127" class="tncms-block"><section id="block-1505127" class="block emphasis-h4   " ><address>
    <strong>baytownsun.com</strong><br>
    1301 Memorial Drive<br>
    Baytown, TX 77520
    <br>
    
        <strong>Phone:</strong> 281-422-8302<br>
        <strong>Email:</strong> <a href="mailto:customerservice@baytownsun.com">customerservice@baytownsun.com</a><br>
    
</address></section></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-1505080" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-1505080"><div class="col-md-7"><small>&copy; Copyright 2022 <a href="/">Baytown Sun</a>, 1301 Memorial Drive Baytown, TX</small><small>&nbsp;| <a href="/site/terms/terms.html">Terms of Use</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-bottom","id":"fixed-impact-bottom","pos":"fixed-impact-bottom, btf","fold":"below","include_domain":null,"size":"[1,1]","height":"1","width":"1","js":{"video":"https:\/\/bloximages.chicago2.vip.townnews.com\/baytownsun.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/obituaries","refresh":false}' style="display:none;"></div>
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("f08040d8-94cf-11ec-84d0-8b847333e4b3")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                _cc14694.add('act', dmpData);_cc14694.bcp();
            });
        });
    
    </script>
    
    
<script>/*<![CDATA[*/ dataLayer.push({
            'tncms.asset.sections': ["obituaries"],
            'tncms.asset.flags': [""],
            'tncms.asset.keywords': ["baytown", "ernestine hunter", "frazier", "christianity", "funeral service", "funeral home", "texas", "viewing"]
        }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/metering/resources/scripts/tnt.metering.c1fd4b9015c14b57a58acdbc3ee4daca.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script>/*<![CDATA[*/ jQuery(document).ready(function($){
                                    $('#weather_zip_toggle_1505138').click(function(e){
                                        $('#weather-1505138 .zip-update-form').toggle('fast');
                                        return false; 
                                    });
                                }); /*]]>*/</script>
<script>/*<![CDATA[*/ (function(d) {
        
        var form = d.getElementById('site-search-1505132'),
            query_input = d.getElementById('site-search-1505132-term'),
            search_dropdown = d.getElementById('site-search-1505132-dropdown');
        
        /** Input focus */
        try {
            search_dropdown.onmouseenter = function(){
                setTimeout(function(){
                    query_input.focus();
                }, 700);
            };
        } catch (error) { 
            // No dropdown behavior
        }
        
        /** Submit handler */
        form.onsubmit = function(){
            // Filter query
            var elem = document.querySelector("#site-search-1505132 input[name=q]"),
        sQueryFiltered = elem.value.replace(/\?/g, '');
    elem.value = sQueryFiltered;
    
            // No submit if empty input
            if( query_input.val() ){
                return true;
            } else{
                return false;
            }
        };})(document); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/withinviewport.1f94ee79a22e6ee8e9c0bb61dec9999b.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.withinviewport.6ef0fee1774e9b313c264a5736522e35.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.scrollstop.934c2bd4d6bebe0494bcb9dd4b1b6ca1.js"></script>
<script>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</script>
<script>/*<![CDATA[*/ function dmpAction(dmpData) {_cc14694.add('act', dmpData);_cc14694.bcp();} /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/editorial/resources/scripts/tnt.poll.aa4a56a35da582e986ed8bbce2004ea4.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/baytownsun.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/maillist_signup.deacc71a82fe583ccc361b42498ff614.js"></script>
<script>/*<![CDATA[*/ $('.mailing-lists input:checked').each(function(){
        var mailListData = 'is_maillist_subscriber: ' + $(this).val();_cc14694.add('act', mailListData);_cc14694.bcp();}); /*]]>*/</script>
<script>/*<![CDATA[*/ function evvntDiscoveryInit_1880979() {
        evvnt_require("evvnt/discovery_plugin").init({
            publisher_id: "baytownsun.com",
            discovery: {
                element: "#evvnt-calendar-1880979",
                detail_page_enabled: true,
                widget: true,
                virtual: false,
                map: false,
                category_id: null, 
                orientation: "portrait",
                number: 3,
            },
            submission: {
                partner_name: "Baytown Sun",
                text: "Promote your event",
            }
        });
    } /*]]>*/</script>
<script>/*<![CDATA[*/ __tnt.log(["The DFP\/GPT Network Code is missing from this ad's definition.","You can find the Network Code by looking at the URL of your DFP admin console: https:\/\/www.google.com\/dfp\/{NetworkCode}#delivery."]); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            jQuery(document).ready(function($){
                var iqLogin = Cookies.get('tnt-iq-login') || false;
                if (__tnt.user.loggedIn && iqLogin == false) {
                    if (__tnt.user.services) {
                        var userServices = __tnt.user.services.split(',');
                        for (i = 0; i < userServices.length; i++) { 
                            var serviceData = 'has_subservice: ' + userServices[i];
                            _cc14694.add('act', serviceData);_cc14694.bcp();
                        }
                    }
                    Cookies.set('tnt-iq-login', 1);
                }
            });
        
            if (window.location.hash){
                var hashSet = ['tncms_source','utm_source','utm_campaign','utm_medium','utm_content','utm_term'],
                    urlHash = window.location.hash.replace('#','').split('&');
                for (var i = 0; i < urlHash.length; i++) {
                    var data = urlHash[i].split('='),
                        param = data[0].replace('-','_');
                    if (hashSet.indexOf(param) != -1){
                        var dmpData = param + ': ' + data[1];
                        _cc14694.add('act', dmpData);_cc14694.bcp();
                    }
                }
            }
         /*]]>*/</script></body>
</html>